Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_window_close_content.py test_close_browserless_tab | Hang in tearDown in headless mode

RESOLVED FIXED in Firefox 59

Status

defect
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: ato, Assigned: whimboo)

Tracking

Version 3
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Reporter

Description

2 years ago
The test_close_browserless_tab test in testing/marionette/harness/marionette_harness/tests/unit/test_window_close_content.py is intermittent, but mostly fails, when run locally.  Confirmed on both macOS and Linux.
Reporter

Updated

2 years ago
Depends on: 1381459
Reporter

Comment 1

2 years ago
Reportedly this is fixed by bug 1417051 because it removes two extra calls to dump TEST-START and TEST-END using WebDriver:ExecuteScript.
Depends on: 1417051
Reporter

Comment 2

2 years ago
Willing to bet this happens because the reference to the current frame is too slow to update and that the content frame script call happens slightly too quickly because headless mode is so fast.
I will see if I can find a reduced testcase.
Summary: Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_window_close_content.py test_close_browserless_tab in headless mode → Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_window_close_content.py test_close_browserless_tab | Hang in tearDown in headless mode
I cannot get this test to fail. Even not with adding other execute_script or execute_async_script calls at the end of the test. Maybe we should mark this bug as fixed?
Flags: needinfo?(ato)
Reporter

Comment 5

a year ago
I want to get back to my Linux workstation in London and try to
reproduce it there before we close.
Reporter

Comment 6

a year ago
It seems dead solid to me now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(ato)
Resolution: --- → FIXED
Assignee: nobody → hskupin
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.