Closed Bug 142348 Opened 23 years ago Closed 22 years ago

Java applet at alnair.de hangs mozilla

Categories

(Core Graveyard :: Java: OJI, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: cochonou, Assigned: joshua.xia)

References

()

Details

(Keywords: hang)

Attachments

(1 file)

Using Mozilla RC1, the two 3D visualisation (the dragon, and the watch) applets
both hang the browser without dislpaying anything after loading the Java
Plug-in. It works fine in Internet Explorer 5 although both browsers have been
configured to use JRE 1.4.0.

Different combinaisons of OS'es and JRE versions will be tried soon.
Keywords: hang
Happens for me too on my home machine; WinXP, {Build ID: 2002042908, 1.0.0+}
JVM 1.4.0.

I can view the "dragon" but the "watch" causes a hang; CPU usage is normal.
Works like a champ under IE6, using both MS and Sun JVMs.
Severity: normal → critical
On 2002050409 Linux (1.0RC2 branch), the applet does not display anything but
Mozilla does not hang.
WFM 2002050504, XP, Java 1.3.1
I'm hitting this too. 2002050406 (1.0RC2 branch), WinME, Java 1.4.0.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug is due to a timing issue, maybe a race condition. I am able to get both
of the applets to work by following this procedure:

1. Close mozilla
2. Open mozilla.
3. Go to http://www.alnair.de/
4. Start a *very* processor-intensive job in the foreground
   (I used video compression with VirtualDub with priority="highest")
5. Click on the applet link
6. Click back on the processor-intensive job so Mozilla stays in the
   background and gets no priority boost.


It takes 5-10 minutes to load the JVM and display the applet, but in the end it
appears.

This is not (of course) a workaround, but it may help in debugging this problem.
R.K.Aa, I'm still seeing this with today's 1.0RC2 branch build (2002050506) on
WinME.

Do you have the opportunity to try it on a branch build and/or with Java 1.4.0?
Blocks: 142810
Just tried on windows 2K, jre: 1.4.0_01 (branch build: 2002-06-04-11-1.0.0), the
applets load pretty quick.
After updating from j2re 1.4.0 to 1.4.0_01, I can now see the watch, but the
dragon hangs.

I am using Mozilla 1.0 on WinME.
Same behaviour under Windows 2000 / Mozilla 1.0 / j2re 1.4.0_01
The watch is working, but not the dragon.

I'll test this under Linux as soon as I get 1.4.0_01 installed there.
Tried it with JRE 1.4.0_01 on Windows XP and Linux, got same results: watch
loaded OK, but not dragon (hung on XP and displayed blank page on Linux).

On the other hand, as the reporter stated, I tried it with JRE 1.3.1 on Windows
XP, it seemed working OK, both watch and dragon got loaded. 

This seems to be an regression on JRE. Re-assign to Java plugin group.
Assignee: joe.chou → James.Melvin
Priority: -- → P2
Joe, I tried both on windows 2000 & linux redhat 7.3 (netscape branch build:
2002-08-13-07-1.0)

Windows 2000 (jre 1.4.0_01)
Linux redhat 7.3 (jre 1.3.1_02)

1. Go to this url:  http://www.alnair.de/
2. On the left page, go to "DEMOS".
3. Click on "Web Client".
4. I see "Dragon, Watch" load fine.
5. Then click on the image of "Dragon or "Watch" so it pops up a bigger image
of "Dragon or Watch". it loads fine on windows 2000, but not on linux redhat
7.3. It generates the errors in the java console window.
Using JRE 1.4.1, you should not be able to see these problems. I tested with 
JRE 1.4.1, it works fine both in Solaris and Windows 2000.
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: James.Melvin → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen
petersen: can you pls verify this as fixed JRE 1.4.1? thanks!
Sure , let me get it installed.
Hmmm. The url provided is no longer valid.
site is down...
reassign to me
Assignee: joe.chou → joshua.xia
site is down...£¡

can reporter provide testcase?

Thanks!
closing due to no testcase.
Reporter: Feel free to reopen if you have new testcase and still has problem
with latest JRE.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: