[Matrox video card] Scrolling crashes browser

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: David W Noon, Assigned: Samir Gehani)

Tracking

({crash})

1.4 Branch
x86
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [See comment 19], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4; en-US; rv:1.0rc1) Gecko/20020418
BuildID:    2002041811

The browser seems to crash, almost at random, when scrolling with the scrollbar
on the right edge of the browser window.

Reproducible: Sometimes
Steps to Reproduce:
1. Open a Web page that more than fills the window.
2. Click the scrollbar on the right.
3. Scroll down.

Actual Results:  
05-05-2002  09:23:01  SYS3175  PID 0089  TID 0001  Slot 006c
H:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1d648ec0
P1=00000002  P2=00000002  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000002  EBX=0012ee24  ECX=01bbff50  EDX=01bda358
ESI=0012ee5c  EDI=01bbff50  
DS=0053  DSACC=d0f3  DSLIM=1fffffff  
ES=0053  ESACC=d0f3  ESLIM=1fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0afb  GSACC=10f3  GSLIM=00003fff
CS:EIP=005b:1d648ec0  CSACC=d0df  CSLIM=1fffffff
SS:ESP=0053:0012edec  SSACC=d0f3  SSLIM=1fffffff
EBP=0012ee48  FLG=00012202

GKCONTNT.DLL 0001:00118ec0

------------------------------------------------------------

05-05-2002  10:45:54  SYS3175  PID 009d  TID 0001  Slot 006f
H:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1d4f5882
P1=00000002  P2=1d7260b8  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=01ec3a58  EBX=1d7260b8  ECX=0012fa88  EDX=0137e380
ESI=00000004  EDI=01b1930c  
DS=0053  DSACC=d0f3  DSLIM=1fffffff  
ES=0053  ESACC=d0f3  ESLIM=1fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0afb  GSACC=10f3  GSLIM=00003fff
CS:EIP=005b:1d4f5882  CSACC=d0df  CSLIM=1fffffff
SS:ESP=0053:0012f9e0  SSACC=d0f3  SSLIM=1fffffff
EBP=0012fa18  FLG=00012203

GKCONTNT.DLL 0001:00005882

------------------------------------------------------------

05-05-2002  12:30:26  SYS3175  PID 00b0  TID 0001  Slot 0069
H:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1bf98c28
P1=00000000  P2=ffffffff  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000400  EBX=00000001  ECX=00000000  EDX=00007fff
ESI=000003f1  EDI=000001bd  
DS=0053  DSACC=d0f3  DSLIM=1fffffff  
ES=0053  ESACC=d0f3  ESLIM=1fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1bf98210  CSACC=d0df  CSLIM=1fffffff
SS:ESP=0053:0012fbc8  SSACC=d0f3  SSLIM=1fffffff
EBP=0000025e  FLG=00012212

DOSCALL1.DLL 0002:00008c28

The above are from 3 separate crashes, not just one crash.

Expected Results:  Text and images should simply scroll.

Warp 4, fixpack 12.
Matrox G400 video adapter, using Matrox drivers.

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
dup of bug 140744 ?
(Reporter)

Comment 2

16 years ago
It's possible that this bug duplicates bug #140744, but the overall system
environment was slightly different between the two instances. At the time the
previous problem arose, the system was heavily loaded. In this newer instance
Mozilla had the machine virtually to itself.

I have also reconfigured the GUI slightly, by removing an OS/2 program called
XWorkplace, which had been causing some difficulties regarding clean shutdowns,
etc. The GUI is back to all-IBM code.
(Reporter)

Comment 3

16 years ago
Here is another crash that occurred in virtually identical conditions: lightly
loaded machine, scrolling a page. This was using RC3 {Build ID 2002052410}.

05-26-2002  23:48:16  SYS3175  PID 0039  TID 0001  Slot 0063
M:\MOZILLA\BIN\MOZILLA.EXE
c0000005
184d1b34
P1=00000001  P2=00414223  P3=XXXXXXXX  P4=XXXXXXXX
EAX=00000001  EBX=00414203  ECX=00010039  EDX=13e8b240
ESI=00000000  EDI=00000000
DS=0053  DSACC=f0f3  DSLIM=ffffffff
ES=0053  ESACC=f0f3  ESLIM=ffffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:184d1b34  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00130f24  SSACC=f0f3  SSLIM=ffffffff
EBP=0100009c  FLG=00010206

PMMERGE.DLL
(Reporter)

Comment 4

16 years ago
And another crash while scrolling down a page (http://news.bbc.co.uk/)

05-28-2002  11:47:55  SYS3175  PID 002d  TID 0001  Slot 005c
M:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1db3af86
P1=00000002  P2=4a816a9c  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=2540b54e  EBX=1d9919cc  ECX=001308cc  EDX=00faa598
ESI=00000001  EDI=1d9919cc  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1db3af86  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:001308dc  SSACC=f0f3  SSLIM=ffffffff
EBP=00130964  FLG=00010206

WDGTOS2.DLL 0001:0000af86
(Reporter)

Comment 5

16 years ago
This time the crash occurred while scrolling upwards, rather than downwards.

05-28-2002  19:17:48  SYS3175  PID 006f  TID 0001  Slot 006b
M:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1e94e389
P1=00000002  P2=00000002  P3=XXXXXXXX  P4=XXXXXXXX
EAX=00000002  EBX=00000000  ECX=00000000  EDX=00000054
ESI=00000000  EDI=00000000
DS=0053  DSACC=f0f3  DSLIM=ffffffff
ES=0053  ESACC=f0f3  ESLIM=ffffffff
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1e94e389  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0012ffdc  SSACC=f0f3  SSLIM=ffffffff
EBP=00130004  FLG=00210246

PMMERGE.DLL 0004:0011e389

In the discussion of bug #140744, Mike Kaply suggested that I try marking the
Mozilla executable for uniprocessor dispatch. I think it is an opportune time to
do that, as I have been allowing it to use both CPUs as it wants.

I think I should also point out that I am using the Modern theme. The scrollers
in that theme behave visibly differently from the scrollers in the Classic theme
in that they change colour when the mouse pointer clicks onto them. [Perhaps the
Classic theme does this too, but if it does then it does so so subtlythat I
cannot see it.]
(Reporter)

Comment 6

16 years ago
Here are two more crashes while scrolling:

05-30-2002  09:35:32  SYS3175  PID 0031  TID 0001  Slot 063
M:\MOZILLA\BIN\MOZILLA.EXE
c0000005
184af61a
P1=00000002  P2=00000001  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000001  EBX=00414204  ECX=00010031  EDX=13e8b240
ESI=00000000  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:184af61a  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00130f25  SSACC=f0f3  SSLIM=ffffffff
EBP=01000088  FLG=00210202

PMMERGE.DLL

-----------------------------------------------------------

05-30-2002  09:45:11  SYS3175  PID 0035  TID 0001  Slot 073
M:\MOZILLA\BIN\MOZILLA.EXE
c0000005
002d010e
P1=00000002  P2=04f60783  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=0152082c  EBX=00f8dd80  ECX=00e30750  EDX=00e8ffb8
ESI=00eff28c  EDI=00e307cc  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:002d010e  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00130f74  SSACC=f0f3  SSLIM=ffffffff
EBP=6e0600e0  FLG=00210206

MOZRMI36.DLL

As you can see, these occurred within 10 minutes of each 
other. There was another, unrelated crash of Mozilla in 
between. So these both occurred within a short time of 
starting Mozilla.

Given the consistent scenario, scrolling with the mouse, 
and the seemingly random locations of the crashes I was 
starting to suspect some external agent, such as the video 
driver. However, no other app suffers in this way; it is 
only Mozilla.
(Reporter)

Comment 7

16 years ago
One further thought:

The major difference between Mozilla and other apps is, indeed, the scrollbars.
Other apps use the native scrollbars supplied by OS/2's Presentation Manager.
Mozilla supplies its own. Since all of these crashes have occurred while
operating a Mozilla-supplied scrollbar, an obvious way to test the relative
stability of Mozilla's would be a facility to revert to native PM scrollbars. I
cannot find any such setting in the preferences dialogue.
uhm, does the problem still exist in 1.1beta?

Comment 9

15 years ago
David, are you still seeing these crashes?
(Reporter)

Comment 10

15 years ago
At present I am still running Mozilla 1.0 GA, so I am still seeing crashes
during scrolling.

I plan to upgrade to 1.2 this weekend and will report again after I have that
running.
(Reporter)

Comment 11

15 years ago
I have just installed Mozilla 1.2b, build id 2002101717, and the following
occurred when scrolling with the scroll bar within a few minutes:

10-27-2002  20:32:50  SYS3175  PID 0046  TID 0001  Slot 0072
M:\MOZILLA_1.2B\BIN\MOZILLA.EXE
c0000005
1e9327e4
P1=00000000  P2=ffffffff  P3=XXXXXXXX  P4=XXXXXXXX
EAX=00000000  EBX=184a75d4  ECX=0000000b  EDX=183da028
ESI=13e60730  EDI=183da028
DS=0053  DSACC=f0f3  DSLIM=ffffffff
ES=0000  ESACC=****  ESLIM=********
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1e9327e4  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00130ce8  SSACC=f0f3  SSLIM=ffffffff
EBP=00130cf0  FLG=00210246

PMMERGE.DLL 0004:001027e4

Comment 12

15 years ago
That's probably a video driver trap, not a Mozilla specific trap.

Can you provide more info on your configuration?
(Reporter)

Comment 13

15 years ago
I am running eCS Pro 1.02 with the SMP kernel. The machine has two Athlon MP
1600+ processors and 512 MiB of RAM.

The video card is a Matrox G400 with 32 MiB of video RAM. The video driver is
SciTech SDD/SE 7.09.

I have tried with the uniprocessor kernel, so that the OS/2 despatcher only uses
one of the CPUs, but similar problems occur. I will try upgrading to the newer
release of SDD this coming weekend.

Comment 14

15 years ago
*** Bug 166244 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 166782 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Summary: Scrolling crashes browser → [Matrox video card] Scrolling crashes browser

Comment 16

15 years ago
When I changed my drivers from version 4.94 to 4.00 mozilla does not crash anymore.
(Reporter)

Comment 17

15 years ago
The version numbers 4.00 and 4.94 don't make immediate sense. Are these the
SciTech driver or the native Matrox driver? I am using the SciTech driver.

Comment 18

15 years ago
I use the native matrox drivers.
(Reporter)

Comment 19

15 years ago
Since I had some spare time this evening and the machine in question wasn't busy
either, I did some experimentation with video drivers. All of this is using the
1.3a build of Mozilla (2002121023).

This issue originally arose using the SDD/se driver for my Matrox G400 video
card. Under this combination, Mozilla would crash at random locations when
updating the screen.

I had the OS/2 boot menu switch back to VGA, which uses the VGAGRADD driver.
Mozilla was still unstable when scrolling.

I then did a SETVGA command and rebooted, which installed the native VGA
hardware driver. Mozilla did not crash at all during this time. It scrolled
without incident.

I then installed the native Matrox driver from the CD that I received with the
video card. Again, Mozilla scrolled without incident. I then increased the
resolution to 1024 x 768 x 16M. Mozilla remained stable and continues to operate
well.

The common denominator in all this is OS/2's GRADD interface, used by both the
SDD and VGAGRADD drivers. The standard VGA and native Matrox drivers both use
the older, 32-bit interface introduced with OS/2 2.11.

At this point, it looks like the traps are caused by GRADD, so perhaps the OS/2
support techs at IBM should take a look.

Comment 20

15 years ago
I get this on my Windows 2000 Professional machine as well. It happens only with
Mozilla.

AMD Athlon 1.2Ghz
512MB PC133 SDRAM
MSI MS-6330 V3.1 motherboard
Matrox G400 16MB DualHead AGP

Windows 2000 Professional SP2
Mozilla 1.3 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3)
Gecko/20030312 with MODERN skin
- driver package 5.32.010
- display/kernel driver/DX 5.12.01.1220 (1.22.024)

When browsing any site that requires the use of the scrollbar, the screen
display will _sometimes_ become corrupted when the scrollbar is clicked or
dragged. (see attachment) If Mozilla is not immediately closed or minimized, the
system locks within a few seconds, requiring a hard reset.

If Mozilla is minimized, the desktop displays properly. If restored from the
taskbar, the screen display will again become corrupted if the scrollbar is
touched. If I go into my video properties and change the screen resolution
before restoring Mozilla, the problem goes away until I make heavy use of
scrollbars again.

Happened with older versions of Mozilla as well. Video drivers must not like
Mozilla...

Comment 21

15 years ago
Created attachment 126327 [details]
This requires a hard reset

Comment 22

14 years ago
Same too happens for me. Mozilla 1.4/Firebird 0.6 (on Win2K) can crash during 
scrolling. The crash always freezes the PC completely and can sometimes result 
in significant screen corruption. Reboot required. The crash happens at least 
once a day (with relatively little usage of the browser).

Gfx card is Matrox G450 dualhead (dualhead mode disabled). Just upgraded to 
latest driver bundle (5.88.061) but the problem persists.

I only noticed the problem after upgrading to Mozilla 1.4, though I'd only used 
1.3 for a relatively short time.

Product: Core → Mozilla Application Suite

Comment 23

11 years ago
Aled,
David,
does this problem still happen for you?
Version: Trunk → 1.4 Branch

Comment 24

11 years ago
(In reply to comment #23)
> Aled,
> David,
> does this problem still happen for you?
> 

No, but I don't use the PC with the G450 graphics card in it anymore! (I think I still have it about somewhere though.)
(Reporter)

Comment 25

11 years ago
(In reply to comment #23)
> Aled,
> David,
> does this problem still happen for you?

I am currently using both Seamonkey and Firefox on a machine with a Matrox G400 video card and both run perfectly well. The major change is that this machine runs Linux, not OS/2. I no longer have the OS/2 box with the Matrox card; my current OS/2 box has an ATI Radeon card in it.

Comment 26

11 years ago
I've upgraded to the beta version of 1.5 and this one solved my issue. Later I upgraded with each new version and the problem never came back.

Later I also moved from the Matrox drivers to the Microsoft drivers for the video card.


Regards,
kmfs

Comment 27

11 years ago
Yes If I remember correct.

I found this solution in a posting on the Mozilla message board. So I tried an it stopped crashing. 

BTW I was using a Matrox G200.

Regards,
Kmfs
MozillaAS v1.4.x is not supported anymore.

Can anyone reproduce with SeaMonkey v1.1.9 ?
(1 month later)

No reply from reporter(s).

R.WorksForMe, per previous comments.

Reopen if you can reproduce with SeaMonkey v1.1.9.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Whiteboard: [See comment 19]
You need to log in before you can comment on or make changes to this bug.