No Cancel button on talkback wizard

RESOLVED WORKSFORME

Status

Core Graveyard
Talkback Client
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: Jon, Assigned: John Morrison)

Tracking

Trunk
mozilla1.4alpha

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

When Mozilla crashes, the talkback wizard starts.  ("Netscape
Quality Feedback Agent - Step 1 of 3").

The text says: ... "Click next to continue.  If you do not want to
run the agent right now, click Cancel." ...
                         ^^^^^^^^^^^^

The "Cancel" button referred to in the text does not exist.  Also,
the window does not have a close button.


Reproducible: Always
Steps to Reproduce:
1. Crash Mozilla


Actual Results:
The talkback window says "... click Cancel", but it does not have a
"Cancel" button.  There is also no close button.

Expected Results:
There should definately be a "Cancel" button.  It would be nice if
there was a close button, too.

Additional Information:
I *assume* that the "Netscape Quality Feedback Agent - Step 1 of 3"
wizard has been installed by Mozilla.  I have also installed Netscape 6
and 6.2 - both of these were installed *before* I installed Mozilla 1.0
RC1.

Workaround:
Go through the wizard.  Step 1 and step 2 merely show information.  At
step 3, choose "Turn agent off" and click "Finish".
(Reporter)

Comment 1

16 years ago
Created attachment 82385 [details]
Screenshot of talkback wizard

Adding a screenshot of the talkback wizard.

Comment 2

15 years ago
We shouldn't have a cancel button there. If you don't want Talkback installed at
all, then either (1) don't download a Talkback build, or (2) Disable Talkback
(at the step after the one in the screenshot. If you want to send some Talkback
incidents and not others, you have that option as well.

I don''t see what the problem is here.
(Reporter)

Comment 3

15 years ago
> We shouldn't have a cancel button there.

Then the dialog box text needs fixing.  From the original report:

: The text says: ... "Click next to continue.  If you do not
: want to run the agent right now, click Cancel." ...

I haven't managed to get Mozilla 1.2.1 to crash (thanks everyone!), so I don't
know if this is still a problem.

Comment 4

15 years ago
I just tested a crash with bug 121533. Talkback comes up, and it has a feedback
agent in build 2003013104 (pre-Mozilla 1.3 beta). 

Reporter, can you download and install the latest nightly build and try this
problem again? Alternatively, wait for Mozilla 1.3 beta to be released. Do you
still see the problem?

Comment 5

15 years ago
andrew: this bug is merely complaining about an inconsistency in the dialog.
it's right (confirming).

I'll attach an rc file containing the three dialogs which the user gets.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Created attachment 116852 [details] [diff] [review]
dialogs

Comment 7

15 years ago
Created attachment 116853 [details] [diff] [review]
remove the line

Updated

15 years ago
Attachment #116853 - Flags: review?(namachi)

Comment 8

15 years ago
could someone please look into making this change?

Comment 9

15 years ago
->jrgm 
Assignee: namachi → jrgm
QA Contact: chofmann → namachi
(Assignee)

Comment 10

15 years ago
we have a build where this is fixed (on win32; need to check osx/linux). 
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4alpha

Comment 11

14 years ago
talkback.xpi from the 1.7a directory does have a Cancel button, so this bug is
fixed, right?
No, this bug is about the talkback program itself. See the attached screenshot
and the original problem description

Comment 13

14 years ago
Created attachment 142992 [details]
"Cancel" button is there now.

Daniel Veditz:
I know what this bug is about. 
Sorry if my comment was not clear enough, what I wanted to say is that the
"Netscape Quality Feedback Agent - Step 1 of 3" dialog window does have a
"Cancel" button now. 
Mentioning the xpi only should make clear that I did *not* use the installer
(that includes talkback), but the zip file (not having talkback for whatever
reasons), and installed talkback.xpi afterwards. While I don't think this makes
a difference wrt the "Cancel" button I still wanted to mention it.

BTW: yes, this button is in all three pages of the Wizard and works at least in
the first one.

Updated

12 years ago
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 350413 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #116853 - Flags: review?(jay)

Updated

9 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
Comment on attachment 116853 [details] [diff] [review]
remove the line

I know it's only been 8 years, but I just don't think you're going to get review on this.
Attachment #116853 - Flags: review?(namachi)
Attachment #116853 - Flags: review?(jay)
"worksforme" based on the second screenshot, but we're no longer using talkback anyway.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.