Text layed out after end of page (table row truncated vertically)

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P2
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Lorenzo Colitti, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc2) Gecko/20020504
BuildID:    2002050406

When this page is loaded for the first time, the text is covered by the black
table row at the bottom. If you reload the page a couple of times, the page is
displayed correctly.

This bug has more serious consequences including, in some cases, rendering text
AFTER the end of a page. To see this text the page must be reloaded. See testcase.

Reproducible: Always
Steps to Reproduce:
1. Go to URL
2. Scroll to end of page

Actual Results:  Note that text is truncated.

Expected Results:  Text is displayed properly and the black table row is laid
out after the end of the text.
(Reporter)

Comment 1

16 years ago
Created attachment 82388 [details]
Testcase

This testcase illustrates the "invisible text after end of page" problem. Make
your Mozilla window short enough to get a vertical scrollbar and reload the
testcase with shift-reload. Now hit reload.

Voila`, the invisible text disappears.
(Reporter)

Comment 2

16 years ago
Sorry, previous comment should have ended with "invisible text APPEARS". If the
window is small enough, the text at the end of the page is invisible until the
page is reloaded.

So, it goes like this:

1. Make Mozilla window medium size.
2. Open attachment 82388 [details] .
3. Resize window vertically until the text "Invisible text here!!!" is
   completely hidden
4. Shift-reload.

Note that you cannot scroll to the "Invisible text here" or see it in any way
except enlarging the window vertically.

5. Reload page without shift.

"Invisible text here!!!" magically appears at the bottom of the page and you can
scroll down to read it.

Comment 3

16 years ago
Confirmed bug on Linux also, 2002-05-04-07 (trunk).
If I select all text (CTRL+A) and paste it into a text editor I see the
invisible text. Seems like the scrollbar believes the document is shorter than
it actually is.
Severity: normal → major
Keywords: testcase
OS: Windows ME → All

Comment 4

16 years ago
Changing priority to P3
Priority: -- → P3
-> Karnaze
Target Milestone: --- → Future
Worksforme with a linux trunk build.... is this still a problem?
(Reporter)

Comment 7

15 years ago
Yes, I still see the problem, both with the URL and the testcase (using the
instructions in comment #2).

Build 2003042608 WinME.
OK, I've managed to reproduce it with a current Linux build too.
Assignee: attinasi → table
Component: Layout → Layout: Tables
Priority: P3 → --
QA Contact: cpetersen0953 → madhur
Target Milestone: Future → ---

Updated

15 years ago
Priority: -- → P2
Target Milestone: --- → Future
(Reporter)

Comment 9

15 years ago
This looks like it's fixed. Will resolve after a couple of tests.
(Reporter)

Comment 10

15 years ago
Can't see this on semi-recent builds of firebird. WFM.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.