All users were logged out of Bugzilla on October 13th, 2018

popup gets not resized between window.open

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
15 years ago

People

(Reporter: markus, Assigned: danm.moz)

Tracking

({compat})

Trunk
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

The URL above shows the problem well.

On subsequent calls to window.open() wich opens a popup with different sizes
(width and height), the parameters are ignored and the popup does not get resized.

Reproducible: Always
Steps to Reproduce:
See http://freeweb.dnet.it/bugzilla/

Actual Results:  Popup size remains unchanged

Expected Results:  Popup window sould be resized according to given parameters

On a short check (by setting status=yes/no and resizable=yes/no) I noted, that
these parameters are affected too, so maybe *all* parameters after the first two
(uri and windowname) to the window.open() function get ignored, if windowname is
already open.
To DOM0...  I'm not sure whether we're supposed to look at the optionstring if
the window already exists.  The fact that IE and NS4 don't agree means there's
no real precedent here...
Assignee: Matti → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
OS: Windows 98 → All
QA Contact: imajes-qa → desale
Hardware: PC → All
INVALID, we don't even look at the options when we're not really *opening* a new
window, nor should we.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Um...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I said INVALID! :-)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
*** Bug 187792 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 158807 has been marked as a duplicate of this bug. ***
*** Bug 227717 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 227717 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
REOPEN for reconsideration.

IE6, NS 4.8 and Opera 7.11 all implements this and they implement it in a
compatible way.  That is, the window is resized according to the new width/height
but the new position is ignored (so the user can move the window and it won't
be reset).
Status: RESOLVED → REOPENED
Keywords: compat
Resolution: INVALID → ---

Updated

15 years ago
Assignee: jst → general
Status: REOPENED → NEW
QA Contact: desale → ian
This would need to be done in the windowwatcher...
(Assignee)

Comment 11

15 years ago
On the comment 0 testsite my copy of IE6 does *not* resize the window. It
resizes the image to display completely. I was with Johnny in comment 2 but I
guess it makes sense -- more sense -- to resize the window. If you know its
name, it would seem a valid assumption that the window is yours.
Assignee: general → danm-moz
(Assignee)

Comment 12

15 years ago
Created attachment 137131 [details] [diff] [review]
resize extant window on window.open with size

This is literally all you have to do. The question is whether we really want to
do this.
(Assignee)

Comment 13

15 years ago
hang on. it's not that simple.
Dan> my copy of IE6 does *not* resize the window

I didn't actually test IE6 myself, I got that info from bug 227717 comment 11.
I realize my mistake now - they use an explicit 'resizeTo' at that URL
(see bug 227717 comment 5).  If IE6 has the same behaviour as Mozilla
currently has then my 'compat' argument falls.

My bad, sorry to have wasted your time.
Exactly.  This resizing thing is a total NS4-ism.  Nothing else does it.
Right, let's end this embarrassment ;-), re-resolving as INVALID!
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.