Closed Bug 1423753 Opened 2 years ago Closed 2 years ago

Can no longer easily drag windows due to tabs

Categories

(Firefox :: Tabbed Browser, defect)

57 Branch
Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1406136

People

(Reporter: kaldari, Unassigned)

Details

In the newest version of Firefox on MacOS (57), I can no longer drag or reposition the browser window since the tabs now completely overlap the title bar except for a tiny bit on the far left and right-hand sides. There are no other MacOS browsers (or applications for that matter) that do this, and it is extremely frustrating. Please provide at least a sliver of title bar above the tabs (like Chrome does), or better yet, a full standard title bar like Safari.
There is empty space before and after the tabs that should allow to easily drag the window. Looks like you noticed it but consider it too small.
You can also use any empty space on the toolbars, that will likely be easier to target since it's usually large.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406136
This isn't a duplicate of 1406136. I'm talking about regular windows, not full screen mode. The basic problem here isn't that it's impossible to drag the window, it's that Firefox breaks 30 years of MacOS application convention and forces the user to figure out how to drag the window, when in every other application (and previous versions of Firefox) it followed the standard convention. Now, every time I use Firefox I end up accidentally spawning new windows by dragging tabs (since they also now look visually identical to the title bar).
You need to log in before you can comment on or make changes to this bug.