Lightweight theme destroys titlebar functionality - window drag

RESOLVED FIXED in Firefox 60

Status

()

defect
P2
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla60
Points:
---

Firefox Tracking Flags

(firefox59 wontfix, firefox60 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
When a lightweight theme is used, the titlebar can no longer be dragged or otherwise interacted with. This applies to the built-in Light and Dark themes as well as themes from AMO.

Applies to latest nightly, browser.tabs.drawInTitlebar = true
Using MOZ_GTK_TITLEBAR_DECORATION=client fixes this for me.
I tried with the built in firefox theme and 3 gnome themes(arc, adapta, adwaita).

Also I think fixing the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1423869 might fix this

Updated

a year ago
Duplicate of this bug: 1428862
(Assignee)

Updated

a year ago
Duplicate of this bug: 1435686
Comment hidden (mozreview-request)

Comment 5

a year ago
mozreview-review
Comment on attachment 8950923 [details]
Bug 1423851 - Enable titlebar/menubar drag on lightweight themes,

https://reviewboard.mozilla.org/r/220178/#review226150
Attachment #8950923 - Flags: review?(dao+bmo) → review+

Comment 6

a year ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/d4937a53d826
Enable titlebar/menubar drag on lightweight themes, r=dao

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d4937a53d826
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.