You can't open the application "FirefoxNightly.app" because it may be damaged or incomplete.

RESOLVED FIXED in Firefox 59

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: vincent.moutoussamy, Assigned: sylvestre)

Tracking

(Depends on 2 bugs, {nightly-community})

59 Branch
mozilla59
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(5 attachments)

Posted image Graphical-error.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

Hit the update button this morning to update FirefoxNightly. Then since it didn't restart automatically, I tried to launch it manually and hit this error message:


Actual results:

You can't open the application "FirefoxNightly.app" because it may be damaged or incomplete.


Expected results:

FirefoxNightly start...
/Applications/FirefoxNightly.app/Contents/MacOS/ seems empty... firefox-bin should have been present but it's not.
Please let me know what log files or details you need to investigate this issue.
Component: Untriaged → Application Update
Product: Firefox → Toolkit
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Version: 57 Branch → 59 Branch
Severity: normal → critical
I just hit this too. It had been a little while (~week?) since I had last restarted, so I restarted once to apply the (old) staged update, then immediately checked for updates and restarted a second time. I wasn't watching exactly what happened, but came back a minute later and was wondering why Nightly wasn't open. Tried to launch it again and got the same error as attachment 8935308 [details].

The contents of /Applications/FirefoxNightly.app are almost completely missing. Looks like the directory structure is still there, but the only files are a few "CodeResources", channel-prefs.js, and update-settings.ini.

Will attach some relevant files / logs next.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a tarball of ~/Library/Caches/Mozilla/updates/Applications/FirefoxNightly/ (too big to attach, alas).

http://dolske.net/mozilla/tmp/last-staged.tgz

Curiously, I have about 200MB(!) of other stuff under .../updates/, but this is the most recent dir that matches the timestamp of when I was updating Firefox.
Posted file update.log
This is just the update.log from within the file in comment 5.
Finally, perhaps coincidence, but I noticed that a fresh download of nightly has "Firefox Nightly.app" (with a space), whereas my broken app was still just "FirefoxNightly.app" (without a space).

Bug 1378834 hasn't landed yet, but Sylvestre says he did just land bug 1407285. Could be a red herring, but FWIW.
Attachment #8935547 - Attachment mime type: text/x-log → text/plain
Comment on attachment 8935553 [details]
Bug 1423856 - Remove the space in the .app files to fix a potential update issue

https://reviewboard.mozilla.org/r/206430/#review212074
Attachment #8935553 - Flags: review?(mh+mozilla) → review+
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3f6d2b219c78
Remove the space in the .app files to fix a potential update issue r=glandium
Also, FTR, from IRC it sounded like this somehow ended up only affecting complete updates, and not partials (which is why some people were able to update to the current nightly without any problem).

As a quick test, I confirmed that downloading an old Nightly and checking for updates reproduced the problem. The old Nightly quits, but the updater never seemed to come up and the resulting FirefoxNighty.app was unlaunchable and empty per comment 3. (Finder gave me a slightly different error when trying to launch, but not sure if that matters.)

I was trying with a build I found from September:

http://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-57.0a1.en-US.mac.dmg
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/ec94a5c11a0a
Remove the space in the .app files to fix a potential update issue. r=glandium, a=RyanVM
https://hg.mozilla.org/mozilla-central/rev/3f6d2b219c78
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Justin, could you double check that my patch fixed the issue?
Merci!
Flags: needinfo?(dolske)
(In reply to Justin Dolske [:Dolske] from comment #11)
> Also, FTR, from IRC it sounded like this somehow ended up only affecting
> complete updates, and not partials (which is why some people were able to
> update to the current nightly without any problem).
> 

given this, I suspect bug 1423571 is related.
Depends on: 1423967
See Also: → 1423571
(In reply to Justin Dolske [:Dolske] from comment #7)
> Finally, perhaps coincidence, but I noticed that a fresh download of nightly
> has "Firefox Nightly.app" (with a space), whereas my broken app was still
> just "FirefoxNightly.app" (without a space).
> 
> Bug 1378834 hasn't landed yet, but Sylvestre says he did just land bug
> 1407285. Could be a red herring, but FWIW.

I may have jumped the gun here. If this is mac only and specifically this issue, bug 1423571 is just a big coincidence?
Yeah, my change is nightly only and bug 1423571 impacts beta! :)
Yeah, I don't think bug 1423571 is related to this; in addition to what Sylvestre pointed out, that bug has to do with downloading the MAR, and in this bug it's already been downloaded and the updater has partially applied it.
See Also: 1423571
Dolkse, it seems that the actual issue was caused by bug 1424294.
I will probably revert https://hg.mozilla.org/mozilla-central/rev/3f6d2b219c78 next week.
Assignee: nobody → sledru
(In reply to Justin Dolske [:Dolske] from comment #11)
> Also, FTR, from IRC it sounded like this somehow ended up only affecting
> complete updates, and not partials (which is why some people were able to
> update to the current nightly without any problem).
> 
> As a quick test, I confirmed that downloading an old Nightly and checking
> for updates reproduced the problem. The old Nightly quits, but the updater
> never seemed to come up and the resulting FirefoxNighty.app was unlaunchable
> and empty per comment 3. (Finder gave me a slightly different error when
> trying to launch, but not sure if that matters.)
> 
> I was trying with a build I found from September:
> 
> http://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
> firefox-57.0a1.en-US.mac.dmg

I saw this, and observed that I was missing `MacOS/firefox` or `MacOS/firefox-bin`, whatever the main executable was.  I downloaded a fresh Nightly DMG and re-installed.
Blocks: 1378834
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d94f6fad91e4
Backed out 5 changesets (bug 1423856, bug 1404796, bug 1378834, bug 1404823) for build bustages on compare-mozconfigs-wrapper.py r=backout on a CLOSED TREE
Depends on: 1426743
Flags: needinfo?(sledru)
My Nightly was busted this morning, and I had to fetch it again from nightly.mozilla.org.  (Mac OS X.)  Is this 'cuz we relanded and are still broken?
https://hg.mozilla.org/integration/mozilla-inbound/rev/c25a7460cbeb5021a1e4913efa8b500bcfb462ab
Bug 1423856 - Backed out changeset 411a410f23b4. Seems that bug 1424294 wasnt' enough to fix it r=me
I thought that bug 1424294 fixed it... Looks like we are not running everything in the CI for nightly updates.
I just backout this change.
(In reply to Sylvestre Ledru [:sylvestre] from comment #30)
> I thought that bug 1424294 fixed it... Looks like we are not running
> everything in the CI for nightly updates.
> I just backout this change.
OS X nightlies are busted since Friday, bug 1410148.
> OS X nightlies are busted since Friday, bug 1410148.
So, you mean this isn't my fault?
I opened bug 1427000 as a follow up bug.
Depends on: 1427000
Pretty sure I no longer need to verify comment 14 is working. :)
Flags: needinfo?(dolske)
You need to log in before you can comment on or make changes to this bug.