[Enhancement] Change the label of the "Clear Form" button to "Clear Autofill Form"

VERIFIED FIXED in Firefox 59

Status

()

--
enhancement
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: Ovidiu, Assigned: ralin)

Tracking

(Blocks: 1 bug)

Trunk
mozilla59
Points:
---

Firefox Tracking Flags

(firefox59 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
This is a proposal for changing the label of the "Clear Form" button with "Clear Autofill Form".

We consider that this change is useful for a better understanding of what clear button does. 

Let's imagine this scenario:


1. You go to amazon.com go to your addresses and create a new address
2. Click on a field and you select one of your saved addresses
3. You want to change the text from a field 
4. Click again on a field and then click on the clear button 



What is happening now: All the data that was filed with autofill is deleted except the one that was updated. 

Enhancement: I think it will be more clear if the text from the "Clear form" button it would be "Clear Autofill Form" because basically, this is what the button does, it clears all the data that was introduced with autofill. 

Please tell me your opinion about this, thanks.
(Reporter)

Updated

a year ago
Blocks: 990176
Thanks for the feedback.

Hi Mark, What do you think?
Flags: needinfo?(mliang)
I agree with that change. With the text being longer, it should follow the text wrapping rule (break into two lines and center aligned if not enough space.)
Flags: needinfo?(mliang)
Thanks, Mark. 

Hi Ray, Could you help on this? Thanks.
Flags: needinfo?(ralin)
(Assignee)

Comment 4

a year ago
Sure, take this.

(In reply to Mark Liang(:mark_liang) from comment #2)
> I agree with that change. With the text being longer, it should follow the
> text wrapping rule (break into two lines and center aligned if not enough
> space.)
I believe current implementation is able to handle it in that way. Thanks
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Flags: needinfo?(ralin)
Blocks: 1404768
No longer blocks: 990176
Comment hidden (mozreview-request)

Comment 6

a year ago
mozreview-review
Comment on attachment 8939494 [details]
Bug 1423873 - Rename the label of clear form button to "Clear Autofill Form".

https://reviewboard.mozilla.org/r/209828/#review215344
Attachment #8939494 - Flags: review?(lchang) → review+
(Assignee)

Comment 7

a year ago
Thanks!

Comment 8

a year ago
Pushed by ralin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/825f84c6efc2
Rename the label of clear form button to "Clear Autofill Form". r=lchang

Comment 9

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/825f84c6efc2
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
(Reporter)

Comment 10

11 months ago
Hi,

I verified this on a Nightly 59.0a1(2018-01-03) Italian build and now the text from "Clear Autofill Form" button is in English but before the fix the text was in Italian. I think the text should be in the same language as the build.
Flags: needinfo?(ralin)
(Assignee)

Comment 11

11 months ago
(In reply to ovidiu boca[:Ovidiu] from comment #10)
> Hi,
> 
> I verified this on a Nightly 59.0a1(2018-01-03) Italian build and now the
> text from "Clear Autofill Form" button is in English but before the fix the
> text was in Italian. I think the text should be in the same language as the
> build.

I think it's because the new string hasn't been translated to Italian yet, once done the text will display in Italian. Thanks.
Flags: needinfo?(ralin)
(Reporter)

Comment 12

11 months ago
Ok, then I think that I need to log another bug to track this, right?
Flags: needinfo?(ralin)
(Assignee)

Comment 13

11 months ago
(In reply to ovidiu boca[:Ovidiu] from comment #12)
> Ok, then I think that I need to log another bug to track this, right?

I don't think we need. Localization is run on separate process and will be applied automatically without changing codebase. We can keep track the issue here, I believe the string will be translated in week if case is Italian.
Flags: needinfo?(ralin)
(Reporter)

Comment 14

11 months ago
I verified this on Mac OS X 10.12,10.11, 10.13, Windows 10 and 7, Ubuntu 16.04 with FF Nightly 59.0a1(2018-01-08) and I can confirm the fix.
Status: RESOLVED → VERIFIED
status-firefox59: fixed → verified
You need to log in before you can comment on or make changes to this bug.