If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

parts of floating elements brought with window when scrolling

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
--
minor
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Bjarne D Mathiesen, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc1) Gecko/20020424
BuildID:    2002042405

If you have windows or other elements that are always floating on top of other
applications, and these are overlapping the Mozilla window, the overlapping
parts are brought with the mozilla window as part of it.
The overlapping applications do still function correctly.

In this case the always floating elements are from:
-- Dragthing 4.2 (running programs)
-- Mail Watcher 2.7 (mailboxes to check)
-- Control Strip

the problem is !!!ONLY!!! present if you scroll the page by using either the
arrow keys or the scrollbar arrows.

the problem is present when scrolling in all directions.

Reproducible: Always
Steps to Reproduce:
1. bring the page display under the floating elements
2. scroll the page


Actual Results:  see attachments

Expected Results:  the page should render without any part of the floating elements

workarounds : 
1) collapse the window - then bring it to full view again.
2) don't have floating elements over the page-display
3) scroll a page at a time

might be related to bug #121713 ???
part of the behaviour as seen in that bug is the same as seen in this bug: when
Screen Catcher has done it's job and the save-dialog is gone, the part of the
page that laid under the save-dialog is displayed correctly.
(Reporter)

Comment 1

16 years ago
Created attachment 82408 [details]
screen after having scrolled backwards
(Reporter)

Comment 2

16 years ago
Created attachment 82409 [details]
screen after Screen Catcher save dialog has disappeared
(Reporter)

Comment 3

16 years ago
Created attachment 82410 [details]
screen after having repositioned mozilla window
(Reporter)

Updated

16 years ago
URL: any any

Comment 4

15 years ago
I can't reproduce this in the July 16th build (2002-07-16-05 1.0.0) under OS 9.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.