Fix instructions font-color in synced tabs sidebar since low contrast and different from the others

VERIFIED FIXED in Firefox 61

Status

()

defect
P3
normal
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: magicp.jp, Assigned: cng)

Tracking

({regression})

Trunk
Firefox 62
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox57 unaffected, firefox58 unaffected, firefox59 wontfix, firefox60 wontfix, firefox61 verified, firefox62 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0 ID:20171207100053

Steps to reproduce:
1. Launch the latest Nightly on Windows
2. Show the Synced tabs sidebar with sign out
3. Open Library button > Synced Tabs
4. Compare font color of instructions "Sign in to..."

Actual Results:
In synced tabs sidebar, instructions font-color is low contrast and different from panelview's one.

Expected Results:
Use same font color with panelview's one.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=126be0de348b73b16f5eda1982c61baa638175ce&tochange=4695551e0df164e6f6c0513b2b992653cd97201a
(Reporter)

Updated

a year ago
Blocks: 1419838
Has Regression Range: --- → yes
Has STR: --- → yes
eoger, could you please look into this?
Flags: needinfo?(eoger)
Keywords: regression
OS: Windows → All
Priority: -- → P3
Hardware: Unspecified → All

Updated

11 months ago
Assignee: nobody → cng
Status: NEW → ASSIGNED
Flags: needinfo?(eoger)
Comment hidden (mozreview-request)

Comment 3

11 months ago
mozreview-review
Comment on attachment 8980042 [details]
Bug 1424100 - Make sidebar text color consistent with panel UI

https://reviewboard.mozilla.org/r/246212/#review252314
Attachment #8980042 - Flags: review?(eoger) → review+

Comment 4

11 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8416a4f99552
Make panel instructions color consistent with sidebar. r=eoger
Comment on attachment 8980042 [details]
Bug 1424100 - Make sidebar text color consistent with panel UI

Alas, this is wrong. It won't work with dark themes such as High Contrast themes on Windows. What you'll probably want to do instead is revert the sidebar to use GrayText again.
Attachment #8980042 - Flags: review-

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8416a4f99552
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/78c400d841f513528536ac3fded97bc31affc4fc
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (mozreview-request)

Comment 9

11 months ago
mozreview-review
Comment on attachment 8980042 [details]
Bug 1424100 - Make sidebar text color consistent with panel UI

https://reviewboard.mozilla.org/r/246212/#review252548
Attachment #8980042 - Flags: review?(dao+bmo) → review+

Comment 10

11 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/40eeaf5f1230
Make sidebar text color consistent with panel UI r=dao,eoger

Comment 12

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/40eeaf5f1230
Status: REOPENED → RESOLVED
Last Resolved: 11 months ago11 months ago
Resolution: --- → FIXED
Looks like a trivial patch, please request Beta approval on it when you get a chance.
Flags: needinfo?(cng)
(Assignee)

Comment 14

11 months ago
Comment on attachment 8980042 [details]
Bug 1424100 - Make sidebar text color consistent with panel UI

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1419838
[User impact if declined]: Text on synced tabs sidebar would be illegible for High Contrast themes on Windows
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: No, minor CSS change
[String changes made/needed]: No
Flags: needinfo?(cng)
Attachment #8980042 - Flags: approval-mozilla-beta?
Comment on attachment 8980042 [details]
Bug 1424100 - Make sidebar text color consistent with panel UI

Small fix to improve panel styling. Approved for 61.0b9.
Attachment #8980042 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 59.0a1 (2017-12-07) on Windows 10, 64 Bit!
This bug's fox is verified with latest Beta and latest Nightly!

Build ID 	20180607135512
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0


Build ID 	20180610220159
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
QA Whiteboard: [good first verify] → [good first verify] [bugday-201800606]
I have managed to reproduce this bug on an affected Nightly build 59.0a1 (2017-12-07), using the STR from comment 0. 

This is verified fixed on latest Beta 62.0b5 (20180702164905) and Release 61.0 (20180621125625) on the following OSes: Windows 10 x64, Ubuntu 16.04 x64 and Mac X OS 10.11.6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.