The Downloads view in the Library window doesn't get focus when opened

VERIFIED FIXED in Firefox 59

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: lists, Assigned: Paolo)

Tracking

({access, regression})

57 Branch
Firefox 60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 wontfix, firefox59 verified, firefox60 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171207220423

Steps to reproduce:

press ctrl + J to focus the downloads list


Actual results:

NVDA says library. I need to press shift + tab to focus and read the list.


Expected results:

NVDA should focus and read the first item in the list.
Reporter

Updated

2 years ago
Keywords: 64bit
Confirmed. Happens with both 32 bit and 64 bit.

Focus lands on the window element with id places. Instead, initial focus should be set to the richlistbox with id downloadsRichListBox.

I seem to recall that this is a regression, but it appears to be the case in 56 at least.
Status: UNCONFIRMED → NEW
Component: Untriaged → Downloads Panel
Ever confirmed: true
Keywords: 64bitaccess
It seems I was incorrect about this being present in Firefox 56.

Last good revision: 5f192263de3e033c3849729724dd388a24dca21e
First bad revision: 56294c9668222e65593818b97b6c9cda4160db54
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5f192263de3e033c3849729724dd388a24dca21e&tochange=56294c9668222e65593818b97b6c9cda4160db54
The only change landed was for bug 1381411.

For reference, this is also being tracked by NVDA: https://github.com/nvaccess/nvda/issues/7779
Keywords: regression
Hi Paolo! Bug 1381411 seems to have broken initial focus in the Downloads Library view. STR:

1. Ensure you have at least one download in your list.
2. Ensure the Library window is closed.
3. Press control+j to open the Downloads Library window.
Expected: The Downloads list (id: downloadsRichListBox) should get focus.
Actual: It doesn't. Focus lands on the window (id: places).

Curiously, if the downloads list is empty, it *does* get focus as expected.

Any ideas as to how this might have regressed?
Flags: needinfo?(paolo.mozmail)

Updated

2 years ago
Summary: NVDA doesn't focus the downloads list → Downloads list doesn't get focus when you press control+j to open the Downloads window
Assignee

Comment 4

2 years ago
I don't know why this has regressed, but it should probably be fixed at some point.
Component: Downloads Panel → Bookmarks & History
Flags: needinfo?(paolo.mozmail)
Priority: -- → P5
Summary: Downloads list doesn't get focus when you press control+j to open the Downloads window → The Downloads view in the Library window doesn't get focus when opened
Assignee

Updated

2 years ago
Duplicate of this bug: 1425734
Assignee

Comment 6

Last year
I might find some time to look into this in the next few days.
Priority: P5 → P3
Comment hidden (mozreview-request)

Comment 8

Last year
mozreview-review
Comment on attachment 8946648 [details]
Bug 1424469 - The Downloads view in the Library window doesn't get focus when opened.

https://reviewboard.mozilla.org/r/216634/#review222708

Thanks.
Attachment #8946648 - Flags: review?(mak77) → review+
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [fxsearch]

Comment 9

Last year
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6aa2d7b4215e
The Downloads view in the Library window doesn't get focus when opened. r=mak
https://hg.mozilla.org/mozilla-central/rev/6aa2d7b4215e
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Assignee

Comment 11

Last year
Comment on attachment 8946648 [details]
Bug 1424469 - The Downloads view in the Library window doesn't get focus when opened.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1381411
[User impact if declined]: Comment 0
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: Comment 3
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Low risk
[Why is the change risky/not risky?]: Simple fix with low chance of making things worse
[String changes made/needed]: None
Attachment #8946648 - Flags: approval-mozilla-beta?
Blocks: 1381411
Version: Trunk → 57 Branch
Verified fixed in Firefox 60.0a1 20180201220225.
Comment on attachment 8946648 [details]
Bug 1424469 - The Downloads view in the Library window doesn't get focus when opened.

Low-risk fix, let's get it in 59b7.
Attachment #8946648 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed using Firefox 59 beta 7 under Win 10 64-bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.