Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Vladimir, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Hi,

   On many Web sites there are links to so called Viewlets.
Clicking on them open a separate browser window (applet ?)
which is an animated demo or tutorial with several controls in it
allowing to control the animation. There are plenty of them in the
URL indicated above. Another URL with such software is
http://www.togethersoft.com/services/tutorials/index.jsp;jsessionid=sisb4mzhc1.www7

These Viewlets do not work.

Reproducible: Always
Steps to Reproduce:
1. Navigate to one of the indicated URL
2. Select any Viewlet link
3. An empty browser window opens

Actual Results:  Empty browser window

Expected Results:  Should be an aimated demo
(Reporter)

Comment 1

16 years ago
For some reasons in the Bugzilla email the link indicated above
got truncated. Here the correct one:
http://otn.oracle.com/products/jdev/viewlets/viewlet.html
Do you have Java installed ?
If yes which version ?
Do you see the java plugin in help/About Plugins ?
(Reporter)

Comment 3

16 years ago
Yes, I do. JDK1.3.1_02.
Yes, I see the java plugin in help/About Plugins?
This Java plugin works well (show all applets) in Sun's javasoft
Web site (http://java.sun.com). Earlier I put all Java required
DLLs which were missed from the original installation of Mozilla.

Agdditional info: It works with Netscape 4.79 and MS IE.

I tested on WinNT with SP 6a.
Can you please install JRE1.4 from (http://java.sun.com/j2se/1.4/download.html) ?

remove the existing Java plugin, install JRER1.4 (which fails to copy the plugin
automatically) and copy c:\programs\Java\Jre1.4..\bin\np*.dll to mozilla plugin
directory, restart mozilla, and try gain ?

(
NPJava11.dll
NPJava12.dll
NPJava13.dll
NPJava32.dll
NPJPI140.dll
NPOJI610.dll
)


wfm with win2k build 20020504.. and JRE1.4
(Reporter)

Comment 5

16 years ago
For some reasoms the NPOJI600.dll was missed and it causes the problem.

We cannot require JRE 1.4 It should work with JRE even older that 1.3.

Anyway the problem was solved.
The JRE1.4 solved many problems in Mozilla.
(hangs, crashes on many applets..)


-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.