Closed Bug 142459 Opened 21 years ago Closed 19 years ago

Shift+click on scroll bar should jump to that location

Categories

(Core Graveyard :: GFX: Win32, enhancement)

x86
Windows 98
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Unassigned)

References

Details

Attachments

(1 file)

Windows scrollbar widgets, when shift is held down, will jump to wherever they
are clicked, as if the mouse had gone to where the grippy was, and dragged it to
its current location. Under windows, mozilla scrollbars should do the same.

Reproducable: always

steps to reproduce:

1 - open an explorer window, and a mozilla window. Point explorer at c:\,
details mode. Open www.theregister.co.uk (or any other page longer than one
screen) in mozilla.

2 - shift-click near the bottom of each scrollbar (but not on the grippy).
Explorer's grippy teleports to the mouse location; mozilla's moves down a page.

3 - If the grippy is large enough, shift-click off of the center of the grippy.
Explorer's grippy centers itself on the pointer; mozilla's does stays still.
Maybe Windows 2000 only?  I can't get this to happen with Windows Explorer in Win98.
It's a win2k thang. There is a duplicate of this (or at least an RFE for 
implementing some of the win2k scrolling inn-o-va-tion).
I have Windows 98.  IE 6 has this feature, and it works even if you click in the
scrollbar thumb (as described by the reporter).  Shift+clicking anywhere in the
elevator pulls the scrollbar thumb so that the center of the thumb is where you
clicked.  Neat feature, I didn't know about it.

Didn't find any dups on the searches:
enh scroll
ALL shift,shft scroll
ALL 2000,2k scroll

jrgm, since you've seen the other bug, do you know how to find it?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Shift+Scroll bar needs to drag → Shift+click on scroll bar should jump to that location
i know i filed a bug about context menus for scrollbars (esp: scroll here). it 
never occured to me that there was a menuless way to get that. wow. (tested 
cmd.exe, nc4.78w32)
See also bug 162620 for Mac (Option-click) and bug 24117 for Linux
(Middle-click, fixed in 2000).
*** Bug 193592 has been marked as a duplicate of this bug. ***
.
Assignee: jag → win32
Severity: trivial → enhancement
Component: XP Toolkit/Widgets → GFX: Win32
OS: Windows 2000 → Windows 98
QA Contact: jrgmorrison → ian
Attached patch Proposed patchSplinter Review
The first two hunks bring shift+click into line with middle click.
The third hunk prevents autorepeat scrolling for shift clicks.
Attachment #134491 - Flags: superreview?(bryner)
Attachment #134491 - Flags: review?(varga)
Comment on attachment 134491 [details] [diff] [review]
Proposed patch

nice notation
r=varga
Attachment #134491 - Flags: review?(varga) → review+
Attachment #134491 - Flags: superreview?(bryner) → superreview+
Comment on attachment 134491 [details] [diff] [review]
Proposed patch

In case you're still accepting enhancements; this patch is low risk because it
reuses all the code that does the hard work. Tested on RH7.3 and MingW builds.
Attachment #134491 - Flags: approval1.6b?
Comment on attachment 134491 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to 1.6beta
Attachment #134491 - Flags: approval1.6b? → approval1.6b+
Fix checked in.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.