Closed Bug 1424666 Opened 4 years ago Closed 4 years ago

Firefox uses too much CPU and battery.

Categories

(Firefox :: Untriaged, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1404042

People

(Reporter: NoahS2003, Unassigned)

Details

(Keywords: power)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171128222554

Steps to reproduce:

Absolutely nothing. Ever since I started using FF (with no addons, no antivirus, no nothing), I consistently encounter this problem.


Actual results:

Whenever I use FF, my fan screams. (Using macBook Pro w/ Retina: macOS High Sierra). As we speak, it's using 180% (!) of my CPU.


Expected results:

It would be nice if I could use FF, at least in normal web-surfing, without my computer draining battery at like 1% every 3min or less.
Keywords: power
This issue seems to be related to Bug 1404042. Considering this I will close this issue as duplicate of it.
Please follow Bug 1404042 and add all your information there.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404042
You need to log in before you can comment on or make changes to this bug.