automatically open the download hanger when a download starts

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: tortino, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171211220110

Steps to reproduce:

1. create a new profile
2. download a file (I tried with an image fro ma web page)
3. the downoad hanger shows
4. redownload a file
5. the dowonload hanger doesn't show anymore
6. in about:flags look for browser.download.panel.shown and set it to false
7. download again and see that the hanger is shown again



Actual results:

The hanger is shown only the first time I download a file


Expected results:

I want the download hanger to be shown every time a download is started.
Also I'd like a config preference to enable or disable the showing of the hanger.

Updated

a year ago
Component: Untriaged → Downloads Panel

Comment 1

a year ago
We investigated this in bug 1269954. There is a lot of work involved in getting the right user interface here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269954

Comment 2

a year ago
(In reply to :Paolo Amadini from comment #1)
> We investigated this in bug 1269954. There is a lot of work involved in
> getting the right user interface here.

Bug 1269954 deals with a lot of UI issues that are unrelated to this request.

A one-line change worked for me in DownloadsCommon.jsm at line 770:
    if (!download.newDownloadNotified) {
      download.newDownloadNotified = true;
      this._notifyDownloadEvent("start");
+     this.panelHasShownBefore = false;
    }

Comment 3

a year ago
(In reply to Bill from comment #2)
> Bug 1269954 deals with a lot of UI issues that are unrelated to this request.
> A one-line change worked for me in DownloadsCommon.jsm at line 770:

These are related in the sense that we cannot do this one-line change without incurring into usability regressions. It's not like anyone missed that line of code, and spent days discussing other solutions unnecessarily...

As far as I can tell right now, we don't have any plans to provide the configuration option you suggested. Although it's a factor in the decision, we don't add configuration options just because they are simple to implement.
Resolution: DUPLICATE → WONTFIX
You need to log in before you can comment on or make changes to this bug.