Box created to contain image is wrong size

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: mozilla, Assigned: troy)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When this page loads at first, notice the empty box in the upper right corner
that is filled with the "Apply to CSU" button. On my box (Win 98 SE, TNT2 Ultra,
NVidia 2.08 reference drivers, 1024x768 16bpp), the initial box is drawn too
big. When the animated GIF finally fills the box, it does not cover up the right
portion of the blank box or the ALT text that was in it.
(Reporter)

Comment 1

19 years ago
Created attachment 1744 [details]
Animated demonstration (12k)

Comment 2

19 years ago
Works for me using recent builds on Windows 98 SE.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

19 years ago
I'm not seeing it with the latest build either, but I certainly believe that it
was a problem. There have been a bunch of incremental reflow bug fixes (by Kipp)
and some fixes to incremental painting (by me) any of which could have fixed
this
(Reporter)

Comment 4

19 years ago
What builds are you referring to? I made the report in reference to 1999091713.
This was also the same build used to make the attachment.
(Reporter)

Comment 5

19 years ago
I just noticed that it only occurs when the horizontal bar at the bottom of
Mozilla is collapsed (the bar with "Mozilla", "Open Windows", etc.).
(Assignee)

Comment 6

19 years ago
I used today's build (built on my machine)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
I can't reproduce the problem in the latest build (1999092208).
(Reporter)

Comment 8

19 years ago
Right, but now collapsing that bottom horizontal bar after the page has loaded
causes that GIF to disappear.

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 9

19 years ago
Reopening because I see this bug in apprunner 1999-10-06-09-M11 on Windows 98
SE. However, it's quite hard to reproduce. Here is what I found out:
A. it doesn't happen on reload; only when loading it for the first time
   after startup
B. it's very sensitive to the width of the window (try ~1040 pixels).
C. I get the feeling that it's a timing thing too, I am using a really slow
   connection (28.8 modem)

Under these conditions it happens once every 10 tries or so.
Resizing or covering the window makes it redraw correctly again.
Attaching a screenshot.

I also see the second problem reported by jerrybaker@weirdness.com on 09/22.
After the page is fully loaded, collapse/expand the bottom toolbar makes the
"Apply to CSU" image disappear and its ALT text is displayed instead, or -
sometimes, the image animation just freezes.
Created attachment 2010 [details]
screenshot of bug
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Comment 11

19 years ago
I hate to be a paint about this, but I just can't reproduce the problem and I
have plenty of other bugs to work on so I'm marking this WORKSFORME again.

If we can find a case that's reproducible I'll be happy to take another look

Comment 12

19 years ago
I can't reproduce the problem either in the latest build (1999101312)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

17 years ago
Mass removing self from CC list.
(Reporter)

Comment 14

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.