Closed Bug 1424949 Opened 2 years ago Closed 2 years ago

Intermittent dom/animation/test/css-animations/test_animations-dynamic-changes.html | Animations are removed from the start of the list while preserving the state of existing Animations - Animations are removed from the start of the list while preserving

Categories

(Core :: DOM: Animation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:logic])

Attachments

(2 files)

This one might be also caused by bug 1424644
Flags: needinfo?(hikezoe)
The failure happens when mPendingReadyTime is clamped to the current time.
 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fcd1137624f1fd79dcb63eb2cf013453d0810def
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Flags: needinfo?(hikezoe)
Comment on attachment 8936880 [details]
Bug 1424949 - Use assert_greater_than or assert_less_than in file_animations-dynamic-changes.html.

https://reviewboard.mozilla.org/r/207604/#review213498
Attachment #8936880 - Flags: review?(bbirtles) → review+
Comment on attachment 8936881 [details]
Bug 1424949 - Wait for one more frame before checking animation start time to avoid the situation that the animation just begins at the time when it's ready.

https://reviewboard.mozilla.org/r/207606/#review213500
Attachment #8936881 - Flags: review?(bbirtles) → review+
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a467c6237e0c
Use assert_greater_than or assert_less_than in file_animations-dynamic-changes.html. r=birtles
https://hg.mozilla.org/integration/autoland/rev/b5f52a71f9a1
Wait for one more frame before checking animation start time to avoid the situation that the animation just begins at the time when it's ready. r=birtles
https://hg.mozilla.org/mozilla-central/rev/a467c6237e0c
https://hg.mozilla.org/mozilla-central/rev/b5f52a71f9a1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1425647
Whiteboard: [stockwell fixed:logic]
You need to log in before you can comment on or make changes to this bug.