Umlaut characters on folder names don't work right

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
--
trivial
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Tuomas Venhola, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When writing a mail, copying it to sent-mail -folder (in Finnish Lähetetyt) says
it's copying mail into "L&AOQ+hetetyt"-folder (or something like that).

My charset is selected to be ISO-8859-15 and the folder names work right in
every other case I've encountered so far.
(Reporter)

Comment 1

16 years ago
Created attachment 82466 [details]
Screen capture of the bug.

This should say "Copying message into Lähetetyt folder..."

Comment 2

16 years ago
Is your account an IMAP account or POP3 account?

Updated

16 years ago
QA Contact: ji → marina

Comment 3

15 years ago
I cannot reproduce this with 01142003 window trunk build. mark it as workforme
I try option->send a copy to
to both imap and pop3 account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
This occurs for "legacy" folders. I'm still encountering some atm. 

Workaround: Quit TB. Find the folder in filesystem. Remove .msf, remove .sdb if empty. Rename folder (and possibly .sdb). Restart TB -> Works.

Apparently it does not concern folders with umlauts that were created after a certain version.
You need to log in before you can comment on or make changes to this bug.