Extensions on private browsing mode

RESOLVED DUPLICATE of bug 1380809

Status

()

Toolkit
WebExtensions: General
RESOLVED DUPLICATE of bug 1380809
a month ago
a month ago

People

(Reporter: gautam.nishchal, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171129230227

Steps to reproduce:

I installed some add ons, then started a private browsing and logged on to my net banking


Actual results:

In private mode, all the add ons were enabled by default


Expected results:

In private mode, none of add ons should be enabled by default, rather, they should be disabled and there should be a page in settings somewhere, where I can "allow an add on in private mode", similar to how it works on chrome.

User might not trust an extension in private mode, (or an add on might be doing something malicious, take some random add on, user installed, but that add on is malicious, logs every URL he visits to and sends to their server), user thinks private browsing is really private browsing :) but in this case, we don't know.

Updated

a month ago
Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Last Resolved: a month ago
Component: Untriaged → WebExtensions: General
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1380809
You need to log in before you can comment on or make changes to this bug.