Hangs browser while printing web page

VERIFIED FIXED in mozilla1.0

Status

()

Core
Printing: Output
P1
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Andy Rudmik, Assigned: dcone (gone))

Tracking

({hang})

Trunk
mozilla1.0
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2], URL)

(Reporter)

Description

16 years ago
Go to above URL.  Click on "Investor Relations" and then trying printing page. 
On MacOS X, the text overwrite the existing page and then the printing dialog
remains - the system does not print page.

I'm using Build ID: 2002050508

Updated

16 years ago
Severity: major → critical
Keywords: hang

Comment 1

16 years ago
->printing
Assignee: Matti → rods
Component: Browser-General → Printing
QA Contact: imajes-qa → sujay

Comment 2

16 years ago
Yes, the page is in a frameset. Attempting to print a frameset will cause this 
problem. When printing the page, two things happen:


1) Print "spooling" never closes
2) Page content is partially duplicated and is overlaid on the page

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Simple test case that contains two frames (inside a frameset). Simply attempting
to print this page will reproduce the problem.


http://mozilla.org/quality/browser/standards/html/frame_name.html

1) Load test case.

2) Choose Print from File menu and click OK.

3) Print spooling dialog appears but doesn't close. Content of the last frame is
duplicated and overlaid on page. Page nevers prints too.
Priority: -- → P1

Comment 4

16 years ago
This is related to http://bugzilla.mozilla.org/show_bug.cgi?id=139233. Since
similar problems occur with iframes.
Keywords: nsbeta1

Comment 5

16 years ago
over to don
Assignee: rods → dcone
Target Milestone: --- → mozilla1.0
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
(Assignee)

Comment 7

16 years ago
*** Bug 139233 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
all platforms are affected by this on branch and trunk builds.  
home.netscape.com is another test case that printing fails at (from duped bug).
OS: MacOS X → All
Hardware: Macintosh → All

Comment 9

16 years ago
I believe this is a Mac only issue (OS X , OS 9) since I can't reproduce this
particular problem on the branch windows build (2002-05-03-06). Nor can I
reproduce the home.netscape.com crash (under the same window branch build).
Tracy, can you try printing the test case in comment 3 with a windows build ? 
then 139233 is NOT a dupe of this.  I cannot print home.netscape.com on 
any platform, branch or trunk.  Going back to reopen that bug. 
damn printer bugs.
nevermind reopening that bug.  I'll log a complewtely new one.  argggh...this 
has not been working for months and each bug get's duped or swallowed up by 
another bug. Please fix not being able to print smoketest printing of 
home.netscape.com.
(Assignee)

Comment 12

16 years ago
I can not repro this bug... I am working on other test cases to see if I can get 
something not working.
my bad, I changed the os to all earlier and forgot to chang it back to just OSX 
when I decided to open another bug for all platforms for what I am seeing.

changing this back to OSX.
OS: All → MacOS X
Hardware: All → Macintosh
Per conversion with dcone: Rod's changes to the printing API's may fix this bug.
This bug is only present on the branch under OSX. It works correctly on the
trunk under OSX.

Comment 15

16 years ago
I can't reproduce the problem with build 2002052503 on 10.1.4. Can anyone with
current build?

Comment 16

16 years ago
I have verified this bug.

Comment 17

16 years ago
PEtersen,can you verify ? thanks...
(Assignee)

Comment 18

16 years ago
I could not reproduce on 9.x operating system.

Comment 19

16 years ago
Yes !! Using the 2002-06-14-05 OS X branch, I can no longer reproduce the
original hang problem. Tested with url and test cases. 
Resolving as fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Keywords: fixed1.0.1

Comment 21

16 years ago
verified on branch.
Status: RESOLVED → VERIFIED
Keywords: verified1.0.1
You need to log in before you can comment on or make changes to this bug.