Port |Bug 1424898 - nsILineBreaker and nsIWordBreaker don't need to be COM services| to mailnews

RESOLVED FIXED in Thunderbird 59.0

Status

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

Trunk
Thunderbird 59.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
mailnews/extensions/bayesian-spam-filter/src/nsBayesianFilter.h:18:10: fatal error: 'nsIWordBreaker.h' file not found
See Also: → 1424912
(Assignee)

Comment 1

a year ago
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8936771 - Flags: review?(acelists)

Comment 2

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/cdceb81023b8
port bug 1424898 to mailnews: nsILineBreaker and nsIWordBreaker are no longer COM services. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Target Milestone: --- → Thunderbird 59.0
(Assignee)

Updated

a year ago
Version: 52 → Trunk
(Assignee)

Updated

a year ago
Summary: Port |Bug 1424898 - patch 1 - De-virtualize nsILineBreaker and rename to mozilla::intl::LineBreaker| to mailnews → Port |Bug 1424898 - nsILineBreaker and nsIWordBreaker don't need to be COM services| to mailnews
(Assignee)

Updated

a year ago
Duplicate of this bug: 1424912

Comment 4

a year ago
Comment on attachment 8936771 [details] [diff] [review]
1425206-breakers.patch

Review of attachment 8936771 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8936771 - Flags: review?(acelists) → review+
You need to log in before you can comment on or make changes to this bug.