Closed Bug 1425227 Opened 2 years ago Closed 2 years ago

The property gridArea returns a malformed value with extra spaces

Categories

(Core :: CSS Parsing and Computation, defect)

58 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: leduc, Assigned: emilio)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171209100033

Steps to reproduce:

In the web console (or in a script file), Set the value of a DOM Element elem like 
elem.style.gridArea = "a";

Then get the value back :
var area = elem.style.gridArea;


Actual results:

The value of the variable area (returned by elem.style.gridArea) is " a /  a /  a /  a" with one space before each "a"


Expected results:

The value should be "a / a / a / a" as it was in previous version of firefox and in other browsers I tried.
If the separator is " / " and the value "a" then it make no sense to add a space before each "a".
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Thanks a lot for the report.
Assignee: nobody → emilio
Fix is at https://github.com/servo/servo/pull/19581. Will write a test as soon as I have a build :)
Depends on: 1425678
Comment on attachment 8937268 [details]
Bug 1425227: Fix grid-layout-properties.html to not depend on buggy Blink / WebKit behavior.

https://reviewboard.mozilla.org/r/207954/#review213800
Attachment #8937268 - Flags: review?(cam) → review+
Comment on attachment 8937268 [details]
Bug 1425227: Fix grid-layout-properties.html to not depend on buggy Blink / WebKit behavior.

https://reviewboard.mozilla.org/r/207954/#review213804
Attachment #8937268 - Flags: review+
Comment on attachment 8937268 [details]
Bug 1425227: Fix grid-layout-properties.html to not depend on buggy Blink / WebKit behavior.

Whoopsies, meant to land it :)
Attachment #8937268 - Flags: review+
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e963388b7ee1
Fix grid-layout-properties.html to not depend on buggy Blink / WebKit behavior. r=heycam
Backout by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/165bf785d9ff
Backout changeset e963388b7ee1 because the OSX build machines don't have Ahem installed. r=backout
https://github.com/w3c/web-platform-tests/pull/8710 is the test change. We should figure out something to run tests with the "ahem" flag properly.
Depends on: 1425698
Status: UNCONFIRMED → NEW
Ever confirmed: true
https://github.com/servo/servo/pull/19581 landed, and the test change will be synchronized on the next WPT sync.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.