Open Bug 1425393 Opened 2 years ago Updated 1 year ago

open service worker tabs in background in about:debugging tests

Categories

(DevTools :: about:debugging, enhancement, P3)

58 Branch
enhancement

Tracking

(Not tracked)

People

(Reporter: jdescottes, Unassigned)

References

Details

Attachments

(1 file)

The goal here is just to use addTab(TAB_URL, { background: true }) instead of addTab(TAB_URL). This way when an about:debugging test times out, we can get helpful screenshot on treeherder. Currently the screenshots always show the service worker page tab, which is a blank tab. I would be more helpful to see the state of about debugging.
Comment on attachment 8936978 [details]
Bug 1425393 - open sw tabs in background in about:debugging tests;

https://reviewboard.mozilla.org/r/207716/#review213600

That trick remember me something... that because we already do that in 2 about:debugging tests.
Attachment #8936978 - Flags: review?(poirot.alex) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec05347a3fae
open sw tabs in background in about:debugging tests;r=ochameau
Thanks for the review, forgot about landing this :)
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/00b1cae7d55f
open sw tabs in background in about:debugging tests;r=ochameau
https://hg.mozilla.org/mozilla-central/rev/95704f0aec0c
Backed out changeset ec05347a3fae for failing devtools/client/aboutdebugging/test/browser_service_workers.js r=backout
https://hg.mozilla.org/mozilla-central/rev/00b1cae7d55f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
It seems that this was actually backed out on autoland?  

Reopened for failures such as https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=6ae11d8f8f770b655990e098ae836f7ec0b9d7ab&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=runnable&filter-searchStr=dt

Looks like this change makes sw tests fail intermittently. Seems to break during unregisterServiceWorker, in parallel there is an error logged for a call to "listWorkers". Need to add logs to unregisterServiceWorker and check what is going wrond here.
Status: RESOLVED → REOPENED
Flags: needinfo?(jdescottes)
Resolution: FIXED → ---
Target Milestone: Firefox 59 → ---
https://hg.mozilla.org/mozilla-central/rev/ec05347a3fae
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Status: RESOLVED → REOPENED
Flags: needinfo?(jdescottes) → needinfo?(toros)
Resolution: FIXED → ---
Target Milestone: Firefox 59 → ---
(wrong ni? sorry)
Flags: needinfo?(toros) → needinfo?(jdescottes)
Can not reproduce the failure on debug locally for now, added some logs at https://treeherder.mozilla.org/#/jobs?repo=try&revision=109d406227a6dc1e23ba072a190890ced550611a
This bug which landed on central, got backed out, and then landed again on central. I assumed the backout had also landed twice, but it didn't. I will backout the patch manually, it is currently causing many intermittents on Windows 7 32 debug (Bug 1428373)
See Also: → 1428373
Product: Firefox → DevTools
Assignee: jdescottes → nobody
Status: REOPENED → NEW
Flags: needinfo?(jdescottes)
You need to log in before you can comment on or make changes to this bug.