mail filter crash [@ nsXULPrototypeCache::GetPrototype]

VERIFIED DUPLICATE of bug 143118

Status

MailNews Core
Filters
--
critical
VERIFIED DUPLICATE of bug 143118
16 years ago
10 years ago

People

(Reporter: Leonard Norrgård, Assigned: Navin Gupta)

Tracking

({crash, testcase, topcrash+})

Trunk
x86
Windows XP
crash, testcase, topcrash+

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0+)
Gecko/20020504
BuildID:    2002050408

Mozilla crashes when either:

In a message window, selecting "Message|Create Filter from Message"

or in the "Tools|Message Filters" clicking on the "New..." button.

Reproducible: Always
Steps to Reproduce:
1. As described above.

This bug appeared in builds from the last few days.
(Reporter)

Comment 1

16 years ago
My own Talkback ID:s related to this bug:

TB5985231Z
TB5985155E
TB5984328M
TB5981292Q
TB5981189K
TB5981147G
Keywords: crash, mozilla1.0

Comment 2

16 years ago
All the talkback incidents are similar. Here's the first one:
INCIDENT 5985231
nsXULPrototypeCache::GetPrototype [nsXULPrototypeCache.cpp, line 279]
nsXULDocument::ResumeWalk [nsXULDocument.cpp, line 5585]
nsXULDocument::OnStreamComplete [nsXULDocument.cpp, line 5898]
nsStreamLoader::OnStopRequest [nsStreamLoader.cpp, line 163]
nsJARChannel::OnStopRequest [nsJARChannel.cpp, line 609]
nsOnStopRequestEvent::HandleEvent [nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [plevent.c, line 597]
PL_ProcessPendingEvents [plevent.c, line 530]
_md_EventReceiverProc [plevent.c, line 1078]
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
_except_handler3()
kernel32.dll + 0x3bb86 (0x77e9bb86) v
(Reporter)

Comment 3

16 years ago
Still valid for 1.0.0+, but removed keyword mozilla1.0 as this doesn't occure on
1.0RC2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2) Gecko/20020506)

Keywords: mozilla1.0

Comment 4

16 years ago
I see no sign of this on 200205004 (today) on win98, so I guess it's just NT
type systems.

Comment 5

16 years ago
This is one of many crashes being reported under the
nsXULPrototypeCache::GetPrototype stack signature in Talkback data.
Keywords: testcase, topcrash+
Summary: mail filter crash → mail filter crash [@ nsXULPrototypeCache::GetPrototype]

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
This crash is most likely related to bug 143118...some change made on 5/3 has
created a lot of crashes since then with this stack signature.
(Assignee)

Comment 7

16 years ago
since we are crashing besides filters here, marking as dup of bug 143118, reopen
if you see this after that bug gets fixed. 

*** This bug has been marked as a duplicate of 143118 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsXULPrototypeCache::GetPrototype]
You need to log in before you can comment on or make changes to this bug.