Closed Bug 1425468 Opened 2 years ago Closed 2 years ago

Add command-line parameters for customizing full installer behavior

Categories

(Firefox :: Installer, enhancement, P1)

Unspecified
Windows
enhancement

Tracking

()

RESOLVED FIXED
Firefox 62
Tracking Status
firefox62 --- fixed

People

(Reporter: mhowell, Assigned: mhowell)

References

Details

Attachments

(1 file)

Currently the full installer accepts only two command-line parameters, one to trigger a silent (GUI-less) installation using the default settings (spelled either /S or -ms), or a second one to specify an INI file containing all other available options (which also triggers a silent install). We should add command-line parameters/flags for the settings that are available in the INI file, so that the installer can be deployed by an administrator with customized settings without also needing to deploy an INI file.
Command line installers does not help. This is something nobody needs. We only need MSI installer or we cannot deploy software via Active Directory. There is nothing to discuss in an enterprise mailing list about this. This is simply waste of time.
Priority: P3 → P2
I'm working on this now.
Priority: P2 → P1
Comment on attachment 8969785 [details]
Bug 1425468 - Add command-line parameters for setting full installer options.

https://reviewboard.mozilla.org/r/238614/#review245354

::: browser/installer/windows/nsis/installer.nsi:225
(Diff revision 1)
>      ${EndIf}
>    ${EndUnless}
>  
> +  ${GetParameters} $R8
> +  ${InstallGetOption} $R8 "RemoveDistributionDir" $R9
> +  ${InstallGetOption} $R8 "PreventRebootRequired" $PreventRebootRequired

Elsewhere $PreventRebootRequired is checked for "true", this will set it to "1" if the switch is present

::: toolkit/mozapps/installer/windows/nsis/common.nsh:5025
(Diff revision 1)
>  
> +      ${GetParameters} $R8
>        ${If} $R8 != ""
> +        ; If there's anything on the command line at all, assume that means
> +        ; we're trying to do a silent install.
> +        SetSilent silent

This should probably be mentioned in the documentation (any command line parameter triggers silent)
Comment on attachment 8969785 [details]
Bug 1425468 - Add command-line parameters for setting full installer options.

https://reviewboard.mozilla.org/r/238614/#review245964

Looks good, thanks!
Attachment #8969785 - Flags: review?(agashlin) → review+
I'm sorry I didn't spot this: UAC elevation in NSIS works by passing an arg to the installer, so if the installer elevates we're always going to be silent.
Comment on attachment 8969785 [details]
Bug 1425468 - Add command-line parameters for setting full installer options.

https://reviewboard.mozilla.org/r/238614/#review246026
Attachment #8969785 - Flags: review+ → review?(agashlin)
Comment on attachment 8969785 [details]
Bug 1425468 - Add command-line parameters for setting full installer options.

https://reviewboard.mozilla.org/r/238614/#review246206
Attachment #8969785 - Flags: review?(agashlin) → review+
Assignee: nobody → mhowell
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48a0e24a2b3e
Add command-line parameters for setting full installer options. r=agashlin
https://hg.mozilla.org/mozilla-central/rev/48a0e24a2b3e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Depends on: 1490264
Depends on: 1500983
Duplicate of this bug: 764709
You need to log in before you can comment on or make changes to this bug.