Crash opening new window and accessing URLbar

RESOLVED WORKSFORME

Status

()

Core
Event Handling
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Eugene Savitsky, Assigned: joki (gone))

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I crashed many times in post RC1 trunk builds opening a new window and when it
loads my  default URL I do CTRL+TAB to accsess the URL bar.

Look at the talkbacks: 
TB5830503Y
TB5848142Q
TB5850503K
TB5903089E
TB5985095Y

And maybe (can't remember for sure):

TB5549613X
TB5567799G
TB5592840H
TB5601094Q
TB5727657Y
(Reporter)

Updated

16 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

16 years ago
Two fresh one's: 

TB6030385W
TB6034160Z

The last crashed with moz 2002050708

Comment 2

16 years ago
tack Signature  nsEventStateManager::IsIFrameDoc 3e5222ff
Email Address ezh@infonet.ee
Product ID MozillaTrunk
Build ID 2002050708
Trigger Time 2002-05-07 11:20:00
Platform Win32
Operating System Windows NT 5.1 build 2600
Module gkcontent.dll
URL visited ezh@infonet.ee
User Comments crash opening new window
Trigger Reason Access violation
Source File Name nsEventStateManager.cpp
Trigger Line No. 4671
Stack Trace
nsEventStateManager::IsIFrameDoc [nsEventStateManager.cpp, line 4671]
nsEventStateManager::ShiftFocusByDoc [nsEventStateManager.cpp, line 4923]
nsEventStateManager::PostHandleEvent [nsEventStateManager.cpp, line 1849]
PresShell::HandleEventInternal [nsPresShell.cpp, line 6009]
PresShell::HandleEvent [nsPresShell.cpp, line 5911]
nsViewManager::HandleEvent [nsViewManager.cpp, line 2030]
nsView::HandleEvent [nsView.cpp, line 306]
nsViewManager::DispatchEvent [nsViewManager.cpp, line 1887]
HandleEvent [nsView.cpp, line 83]
nsWindow::DispatchEvent [nsWindow.cpp, line 871]
nsWindow::DispatchWindowEvent [nsWindow.cpp, line 888]
nsWindow::DispatchKeyEvent [nsWindow.cpp, line 2666]
nsWindow::OnKeyDown [nsWindow.cpp, line 2741]
nsWindow::ProcessMessage [nsWindow.cpp, line 3546]
nsWindow::WindowProc [nsWindow.cpp, line 1133]
USER32.dll + 0x3a5f (0x77d43a5f)
USER32.dll + 0x3b2e (0x77d43b2e)
USER32.dll + 0x3d6a (0x77d43d6a)
USER32.dll + 0x41fd (0x77d441fd)
nsAppShellService::Run [nsAppShellService.cpp, line 451]
main1 [nsAppRunner.cpp, line 1472]
main [nsAppRunner.cpp, line 1808]
WinMain [nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
kernel32.dll + 0x1eb69 (0x77e7eb69) 
-> Events
Assignee: Matti → joki
Component: Browser-General → Event Handling
QA Contact: imajes-qa → rakeshmishra

Comment 4

16 years ago
related: bug 141807.
(Reporter)

Comment 5

16 years ago
I can 100% repro it.

1. load rus.delfi.ee
2. During loading press randomly CTRL+TAB. 
3. 99% crash.

I lost many time already with this crashing loosing all my opened pages. :(

I'll try with a new profile to be sure it's profile independed.
(Reporter)

Comment 6

16 years ago
OK. It's profile and skin independend.

But it seems that it does not crash on all URLs. www.uno.ee - did not crashed
for me. But www.kaspersky.ee - crashed.

And one more: during loading a URL you can press CTRL and press quickly TAB.
(Reporter)

Comment 7

16 years ago
Can somebody look at this? I tested it on 2 XP computers - same crash.

Comment 8

16 years ago
ok, reproduced with mozilla trunk 2002-05-18-08/win2k loading default mozilla
startup page. Could not reproduce in branch 2002-05-17-06/win2k.

TB: 6506419
Sig: nsEventStateManager::IsIFrameDoc b8e8a093
(Reporter)

Comment 9

16 years ago
WFM now. 2002070310
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.