Open Bug 1425531 Opened 2 years ago Updated 2 years ago

Unable to run mochitests by chunk on windows (twisted requires MSVC++ 9.0)

Categories

(Testing :: Mochitest, defect)

57 Branch
defect
Not set

Tracking

(Not tracked)

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

Attached file Log
On a Windows 10 64-bit machine, with visual studio 2017, and the patch from bug 1425527 applied, I tried to run:

./mach mochitest --total-chunks=5 --this-chunk=5

and it errored out. From the output it looks like we're trying to build twisted and it wants Visual C++ 9.0 which I don't have on my machine, and which I don't think mozilla-central builds on any more.

Full log attached.
oh, this is just silly, I see where we need twisted:
https://searchfox.org/mozilla-central/source/testing/tools/websocketprocessbridge/websocketprocessbridge_requirements.txt

not sure why we need that, but a fix should be done anyway.  These tests currently run on windows 10, possibly you need to install the toolchain on your local machine?
It doesn't seem to try to install twisted if I run a single mochitest or a folder of them. It's only with chunking that this happens. Seems like we should definitely be able to remove this requirement; I commented it out in the websocketprocessbridge_requirements.txt file and now the tests seem to be running fine as far as I can tell.
We can't remove it unfortunately, though it's only needed by the media mochitests:
https://searchfox.org/mozilla-central/source/testing/mochitest/mach_commands.py#360

So any command that would result in a media test being run, will attempt to install it.
Ok, I'll just run with it commented out locally for now.
Summary: Unable to run mochitests on windows (twisted requires MSVC++ 9.0) → Unable to run mochitests by chunk on windows (twisted requires MSVC++ 9.0)
You need to log in before you can comment on or make changes to this bug.