Closed Bug 1425736 Opened 2 years ago Closed 2 years ago

Downloads button in overflow panel - failure attention badge misplaced above the hamburger button

Categories

(Firefox :: Toolbars and Customization, defect, P3, minor)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: taroxd, Assigned: Paolo)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171206182557

Steps to reproduce:

Hide the download button in the overflowed menu. Then download a file and make the download fail.


Actual results:

A misplaced yellow spot showed on the hamburger button. See the screenshot for detail.


Expected results:

The yellow spot should have occured above the overflowed menu.
Attached image Screenshot
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
20171217100047
Severity: normal → minor
Status: UNCONFIRMED → NEW
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: Untriaged → Theme
Ever confirmed: true
Summary: Misplaced small yellow spot above the sandwich button → Downloads button in overflow panel - failure attention badge misplaced above the hamburger button
Component: Theme → Downloads Panel
This bug likely belongs to Toolbars and Customization as the overflow and menu buttons live there.
Component: Downloads Panel → Toolbars and Customization
(In reply to :Paolo Amadini from comment #3)
> This bug likely belongs to Toolbars and Customization as the overflow and
> menu buttons live there.

I mean, not really... the downloads button has the code that adds this badge to the hamburger button. The only other badges I'm aware of are for add-ons and updates, and those continue to make sense on the hamburger button. So the only thing that needs fixing is how the downloads button sets this badge.

To fix this we'd need to either duplicate the app menu badge logic code to have a separate badge status for the overflow panel (and adapt the CSS), or somehow make the location of the badge and/or notification anchor configurable within the current "AppMenuNotifications" class/object, which also seems wrong because "AppMenu" is right there in the name.

What did we use to do when the downloads button was in the "dynamic" overflow panel on pre-57 releases? I can't test myself because I'm not sure how to make a download fail...

In any case, doing whatever that was (which might be "nothing, no badge would have been shown") would be the most expedient solution here, though perhaps not the best.
Flags: needinfo?(paolo.mozmail)
Priority: -- → P3
(In reply to :Gijs from comment #4)
> What did we use to do when the downloads button was in the "dynamic"
> overflow panel on pre-57 releases? I can't test myself because I'm not sure
> how to make a download fail...

One simple way to make a download fail is to download behind a local proxy (Fiddler, for example) and close that proxy.
(In reply to :Gijs from comment #4)
> I mean, not really... the downloads button has the code that adds this badge
> to the hamburger button.

Well, as you say we'd need a new customization API first, as badges can't be shown on the overflow button.

> In any case, doing whatever that was (which might be "nothing, no badge
> would have been shown") would be the most expedient solution here, though
> perhaps not the best.

I tested Firefox 56 and as I expected we don't show a badge on the overflow button. In Firefox 52, we don't show a badge on the menu button either when the Downloads button is moved to the menu.

I would agree that developing a new API for the badge is overkill and we can just do what we did before.

(In reply to taroxd from comment #5)
> One simple way to make a download fail is to download behind a local proxy
> (Fiddler, for example) and close that proxy.

Another way is to paste a link to a non-existent domain like <http://nonexistent.example.com/> in the Downloads View in the separate Library window.
Flags: needinfo?(paolo.mozmail)
Comment on attachment 8941100 [details]
Bug 1425736 - Don't show the attention badge for download failures on the application menu button.

https://reviewboard.mozilla.org/r/211372/#review217172

Thanks for jumping on this. This change makes sense to me. Should we have a follow-up bug for adding some kind of badge support to the overflow button? I imagine add-ons might find it useful, too.
Attachment #8941100 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs from comment #9)
> Should we have a
> follow-up bug for adding some kind of badge support to the overflow button?
> I imagine add-ons might find it useful, too.

I'd leave that to the add-ons team, if this turns out to be a desired feature. For downloads, I don't think it's important right now.
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/65454ea1fbe4
Don't show the attention badge for download failures on the application menu button. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/65454ea1fbe4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Duplicate of this bug: 1442274
Assignee: nobody → paolo.mozmail
You need to log in before you can comment on or make changes to this bug.