Closed Bug 1425984 Opened 2 years ago Closed 2 years ago

Backport clang revision 318309 to fix Windows clang-cl bustage with VS2017 15.5

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

As mentioned in bug 1423307, Windows static analysis builds break on Try when trying to build with VS2017 15.5 due to _float128 issues that were fixed upstream. I've confirmed that the upstream fix backports cleanly and fixes the issues on Try while also not regression existing builds with 15.4.
Duplicate of this bug: 1425983
Attachment #8937570 - Flags: review?(dmajor)
Blocks: VS15.6
Attachment #8937570 - Flags: review?(dmajor) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3d811fe03286
Backport LLVM revision 318309 to fix clang-cl bustage with VS2017 15.5. r=dmajor
https://hg.mozilla.org/mozilla-central/rev/3d811fe03286
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.