Setting Mozilla as default browser disables OS X Email links

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Blake Learmonth, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+)
Gecko/20020430
BuildID:    2002043003

When Mozilla is set as the default browser in OS x's Systems
Preferences>internet>default web browser>Mozilla, OS X's native mail program
can't open the browser to view Email links.  May be an OS X bug not a Mozilla
bug. Switching back to IE fixes the problem.

Reproducible: Always
Steps to Reproduce:
1.Set Mozilla as default Web Browser
2.open an Email with OS X's mail program that contains links
3.Click a link ... nothing happens
4. Switch bact to IE
5.Repeat 1,2,and 3... link works

Actual Results:  see 3. above; link does not open

Expected Results:  Link should open in Mozilla
-> Xp APPS
Assignee: Matti → sgehani
Component: Browser-General → XP Apps
QA Contact: imajes-qa → paw

Comment 2

16 years ago
This is present in 2002050408 as well as the RC1 build.  

The problem appears to be all invocations of the default browser, not just
from Apple Mail (OS X Mail.app), e.g., Image Capture's web page builder script.

Nothing has changed in OS X - this worked fine in at least a 200204017 build. 

Comment 3

16 years ago
Marking confirmed per comment 2. Blake, Michael, can you two both still
reproduce this using a current build?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
OS X 10.2.3 (6G30), Mail.app 1.2.3 (v551), Mozilla 1.3b 20021227, works for me.

I can click links in email just fine. Links also work fine in BBEdit, Eudora, etc. 

Blake, Michael, are you using 10.1 or 10.2?

Comment 5

15 years ago
this all WFM 1.4b OSX.. please speak up if this is still a problem for anyone
using a current build

Comment 6

15 years ago
-> WFM per comment 5.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.