Closed Bug 1425999 Opened 2 years ago Closed 2 years ago

dom.disable_window_status_change is obsolete

Categories

(Core :: DOM: Core & HTML, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: adni.online, Assigned: Nika)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171130114032

Steps to reproduce:

1. Change dom.disable_window_status_change in about:config to false.
2. Set window.status to a string value in JavaScript.


Actual results:

No change from default behavior, there is no effect on the status bar.


Expected results:

The status bar should show the string window.status was set to.
Component: Untriaged → DOM
Product: Firefox → Core
Nika, can you please take a look?
Flags: needinfo?(nika)
Priority: -- → P3
Consulting the HTML Living Standard and the W3C HTML5 changelog (https://www.w3.org/TR/2012/WD-html5-diff-20121025/) as well  as bug 863339 I believe this (non)behavior is intentional and according to spec.
Accordingly, the preference should be removed and (most importantly!) the appropriate documentation updated.
Summary: dom.disable_window_status_change=false has no effect → dom.disable_window_status_change is obsolete
It looks like we never got around to implementing this API in e10s. The object which should implement `setStatus` in e10s doesn't have any `setStatus` implementation: (https://searchfox.org/mozilla-central/rev/22c55eb7b7e6494a8615a7af3b613ff899d2cdba/browser/base/content/tab-content.js#697-735). This is fine, because as comment 2 notes, this is a deprecated API and we don't have it enabled by default.

I imagine we can probably remove the pref & restrict callers to chrome code in the parent process.
Flags: needinfo?(nika)
MozReview-Commit-ID: 1O6ff22IcZZ
Attachment #8938522 - Flags: review?(kyle)
Assignee: nobody → nika
Comment on attachment 8938522 [details] [diff] [review]
Remove the dom.disable_window_status_change pref, as it no longer can be disabled

Review of attachment 8938522 [details] [diff] [review]:
-----------------------------------------------------------------

OH COME ON I'M ON VACATION.

*goes back to sitting here writing code for own projects*
Attachment #8938522 - Flags: review?(kyle) → review+
Pushed by nika@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b86850493c20
Remove the dom.disable_window_status_change pref, as it no longer can be disabled, r=qdot
https://hg.mozilla.org/mozilla-central/rev/b86850493c20
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.