Closed Bug 1426118 Opened 2 years ago Closed 2 years ago

Turn on webgl mochitests for windows10-64 QR builds

Categories

(Core :: Graphics: WebRender, defect, P1)

Other Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted][triage])

Attachments

(1 file)

Based on earlier try pushes the mochitest-webgl jobs seem to be green on windows10-64 runs with webrender enabled. We should turn these on to prevent them from regressing.
Hm, looks like the debug jobs now are quite blue (probably OOMing). Not sure if this is a regression from the try push I did in bug 1424755 comment 4 or if it was just a fluke but I need to solve this problem for other win10 debug tests anyway so I'll try and repro locally.
New try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=3159516db72723617db06ed19ce38390370826be

Still showing a lot of blue, too much for my liking. I'll try to get a loaner and dig into it.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3fc69d44b2867727f4566a2399a4340bea9c60ea

About the same blue as before, but more evenly distributed across the jobs. Not sure if that's progress :/
Actually it *is* much better. Previously on a single retrigger (16 jobs) there were 13 blues. This time I had retriggered each job twice more, so for the 48 jobs there were only 18 blues.

But in theory I have access to a loaner now so I can dig into it a bit more.
Comment on attachment 8953600 [details]
Bug 1426118 - Turn on webgl mochitests for windows10-64 QuantumRender builds.

https://reviewboard.mozilla.org/r/222800/#review229334
Attachment #8953600 - Flags: review?(dustin) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc147bc11c0e
Turn on webgl mochitests for windows10-64 QuantumRender builds. r=dustin
https://hg.mozilla.org/mozilla-central/rev/cc147bc11c0e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d3b20e603c5f
Partial backout of cset cc147bc11c0e . r=me on a CLOSED TREE
I disabled the mochitests temporarily because bug 1440664 made them go somewhat orange. Will investigate and reland eventually.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/82c009dbf592
Partial backout of cset cc147bc11c0e . r=me a=webgl-fix
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/58b3bc37c7f8
Re-enable mochitest-webgl for windows10-64-qr. r=me
https://hg.mozilla.org/mozilla-central/rev/58b3bc37c7f8
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.