Closed Bug 1426190 Opened 2 years ago Closed 2 years ago

JS module test for integrity attribute fails

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(1 file)

No description provided.
Priority: -- → P3
The integrity metadata used for fetching descendent module scripts is supposed to be empty:

https://html.spec.whatwg.org/#descendant-script-fetch-options

The patch changes the ModuleLoadRequest constructor that is used for fetching descendent modules.
Attachment #8938068 - Flags: review?(bugs)
Attachment #8938068 - Flags: review?(bugs) → review+
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/56a67e62f5cb
Integrity option for descendant module scripts should be the empty string r=smaug
https://hg.mozilla.org/mozilla-central/rev/56a67e62f5cb
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1406151
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.