Status

()

Core
Audio/Video: cubeb
--
major
RESOLVED DUPLICATE of bug 1426719
a month ago
15 days ago

People

(Reporter: perosmct, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3299.0 Safari/537.36

Steps to reproduce:

Since latest Windows 10 insiders 17063 build, I have no audio/sound at least HTML5 I am aware of. Flash content for example has audio. Please inform coders/debuggers to fix it ASAP if possible with Nightly builds at least. I need Firefox, I love Firefox. I have also informed Microsoft for their next insiders build.


Actual results:

I have tried Stable, Beta and Nightly versions both x86 & x64 builds. I had audio yesterday with previous 17046 build. Chrome and Edge still have audio/sound everywhere though.

It happened suddenly. No sound icon when HTML5 content is playing in tab above you know Youtube for example. It doesn't trigger audio playback(nothing shows even in windows mixer simply Firefox doesn't want or is unable to output any audio from source).


Expected results:

Play audio/sound ofcourse, I want music and videos with audio! I have tried everything. Don't lead me to other posts about refreshing, new account, safe mode, incognito etc, older versions. Nothing works. Investigate program's code and latest extensions in harmony with latest windows components. Something is newly broken.

I await good news about fixing that rather irritating bug. Happy Holidays! Thanks!

Updated

a month ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Updated

a month ago
Duplicate of this bug: 1426293

Comment 2

a month ago
In addition I could add that error code is NS_ERROR_DOM_MEDIA_MEDIASINK_ERR(OnMediaSinkAudioError )

Comment 3

a month ago
A Microsoft engineer posted onto the Windows 10 Feedback Hub a write up describing why this has occurred: https://aka.ms/Fpb330 (you need Windows 10 and the Anniversary Update or above to view this).

Apparently the Windows sound APIs was changed in 17063 to have them, and I quote, "return S_FALSE (1) if the requested change was a no-op." Firefox seems to "request changes (that may be no-ops) and then explicitly check the return value against S_OK (0)."

So Firefox needs to be updated to cooperate with the API change.
Component: Audio/Video: Playback → Audio/Video: cubeb
Flags: needinfo?(cchang)

Comment 4

a month ago
https://www.reddit.com/r/Windows10/comments/7kzt7s/psa_if_you_use_firefox_dont_upgrade_to_17063_it/drirymw/

Is this required be fixed in Firefox? Maybe should wait for the patch from Windows.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 10
Hardware: Unspecified → All

Comment 5

a month ago
(In reply to YF (Yang) from comment #4)
> https://www.reddit.com/r/Windows10/comments/7kzt7s/
> psa_if_you_use_firefox_dont_upgrade_to_17063_it/drirymw/
> 
> Is this required be fixed in Firefox? Maybe should wait for the patch from
> Windows.

According to a MS engineer on r/Windows10, this should be patched, but it might take a while (he said that he doesn't expect a hotfix and he's not even sure if it'll be fixed in the next build released). Here's that Reddit post btw: https://www.reddit.com/r/Windows10/comments/7kzt7s/psa_if_you_use_firefox_dont_upgrade_to_17063_it/

Comment 6

a month ago
The same MS engineer posted the exact steps needed to change the source to workaround this bug:

Very plausible. Workaround would be to change https://dxr.mozilla.org/mozilla-central/source/media/libcubeb/src/cubeb_wasapi.cpp as follows

hr = stm->audio_stream_volume->SetAllVolumes(channels,  volumes);
if (hr != S_OK) {
    LOG("could not set the channels volume: %lx", hr);
    return CUBEB_ERROR;
}

to

hr = stm->audio_stream_volume->SetAllVolumes(channels,  volumes);
if (FAILED(hr)) {
    LOG("could not set the channels volume: %lx", hr);
    return CUBEB_ERROR;
}

Source: that Reddit thread
(Reporter)

Comment 7

29 days ago
Close it. You fixed it with the latest Nightly build 22 Dec 2017.

Thanks. Everything works ok. That's why I love Nightly more. Instant fixes if possible. :)

Comment 8

28 days ago
I believe this bug is a duplicate of 1426719 - Can someone verify and mark as duplicate?
https://bugzilla.mozilla.org/show_bug.cgi?id=1426719

Updated

28 days ago
Status: NEW → RESOLVED
Last Resolved: 28 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426719
Flags: needinfo?(cchang)
You need to log in before you can comment on or make changes to this bug.