Closed Bug 1426395 Opened 3 years ago Closed 2 years ago

Crash in mozilla::dom::cache::ReadStream::Inner::EnsureStream

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox58 --- wontfix
firefox59 --- ?

People

(Reporter: jya, Unassigned)

References

Details

(Keywords: regression)

Crash Data

Crash Signature: [ @mozilla::dom::cache::ReadStream::Inner::EnsureStream ] → [@mozilla::dom::cache::ReadStream::Inner::EnsureStream]
This code needs to handle spurious wakeups from the condition variable:

https://en.wikipedia.org/wiki/Spurious_wakeup
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
I guess the problem is actually this, instead:

MOZ_CRASH(Blocking read on the js/ipc owning thread!)
Or maybe its not comment 2 since the stack trace is non-main-thread and also doesn't show anything about worker threads.
Summary: Crasn in mozilla::dom::cache::ReadStream::Inner::EnsureStream → Crash in mozilla::dom::cache::ReadStream::Inner::EnsureStream
This seems like broken TLS to me.  I've seen some other low-frequency crashes recently that also seemed related to TLS not working correctly.
This also hasn't had any crashes in 57 release channel for some reason.

I think I'm going to monitor this for now.  Its unclear what we can do here.
Its also possible the ReadableStream is garbage I suppose and the TLS check is failing because mOwningEventTarget is a bad pointer.
Priority: -- → P3
Severity: normal → critical
I'm not actively working this.  Its very low frequency and I don't have any good options to move forward at the moment.
Assignee: bkelly → nobody
Status: ASSIGNED → NEW
Severity: critical → major
Thanks, Wayne.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(overholt)
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.