Closed Bug 1426450 Opened 2 years ago Closed 2 years ago

Update HarfBuzz to 1.7.4

Categories

(Core :: Graphics: Text, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

Overview of changes leading to 1.7.4
Wednesday, December 20, 2017
====================================

- Fix collect_glyphs() regression caused by hb_set_t changes.

Interesting that our own regression tests didn't see this bug, but Google's did.
Comment on attachment 8938079 [details] [diff] [review]
update harfbuzz to version 1.7.4

Review of attachment 8938079 [details] [diff] [review]:
-----------------------------------------------------------------

Yep - I think it's possible harfbuzz issue 657 might have affected us (in rare cases), so it's good to get this fixed.
Attachment #8938079 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/8ee567b6b415
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Blocks: 1434447
You need to log in before you can comment on or make changes to this bug.