Closed Bug 1426500 Opened 2 years ago Closed 2 years ago

Enable WebVR for macOS only on Nightly and Dev-Edition

Categories

(Core :: WebVR, defect, P1)

58 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 blocking verified
firefox59 --- fixed

People

(Reporter: kip, Assigned: kip)

References

Details

Attachments

(2 files)

The webvr pref, dom.vr.enabled, needs to be disabled for beta and release for the macOS platform.  This is due to inability to QA macOS support for WebVR on currently available hardware.  macOS support for WebVR will remain enabled on Firefox nightly and dev-edition.  Support for WebVR on Windows will remain enabled in all 64-bit desktop Firefox builds, including release.
Note that the macOS support will be enabled for dev-edition, but not Beta.  These changes will be reverted once QA with supported configurations becomes possible.  It will also be possible to manually enable WebVR in release builds in about:config by flipping dom.vr.enabled
SoftVision has not yet been able to verify for QA due to technical issues with the macOS devkit hardware.  As FF58 is about to merge, I am prioritizing this.
Priority: -- → P1
Target Milestone: --- → mozilla58
Version: 59 Branch → 58 Branch
Attachment #8941669 - Flags: review?(dmu)
This patch applies cleanly on Beta and can be used for beta-uplift
I will request beta-uplift as soon as the try run passes with green and have r+.
Comment on attachment 8941669 [details]
Bug 1426500 - Disable WebVR for macOS on Beta and Release

https://reviewboard.mozilla.org/r/211908/#review217700

lgtm. Thanks
Attachment #8941669 - Flags: review?(dmu) → review+
Pushed by kgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/78533a254124
Disable WebVR for macOS on Beta and Release r=daoshengmu
Comment on attachment 8941669 [details]
Bug 1426500 - Disable WebVR for macOS on Beta and Release

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 1374399 - Enable WebVR by default on macOS

[User impact if declined]:
WebVR will be enabled on macOS in release Firefox 59.  Although this is working well on our development machines, it has not been verified by SoftVision due to hardware issues (eGPU DevKit enclosure supplied by Apple is crashing their test machines.)

[Is this code covered by automated tests?]:
Yes.  The automated reftets, mochitests, and web-platform-tests for WebVR will continue to run.

[Has the fix been verified in Nightly?]:
WebVR will continue to be enabled in Nightly and Dev Edition, but will be disabled in Release and Beta until the SoftVision QA can be completed.

[Needs manual test from QE? If yes, steps to reproduce]: 
N/A - Simply ensuring that functionality does not become enabled in release.

[List of other uplifts needed for the feature/fix]:
N/A

[Is the change risky?]:
Low Risk.

[Why is the change risky/not risky?]:
Change reduces risk by delaying functionality that has not been shipped in release until QA verification.

[String changes made/needed]:
N/A
Attachment #8941669 - Flags: approval-mozilla-beta?
Comment on attachment 8941669 [details]
Bug 1426500 - Disable WebVR for macOS on Beta and Release

Take this to enable WebVR for macOS only on Nightly and Dev-Edition. Beta58+.
Attachment #8941669 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/78533a254124
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
This patch should fix the test failure that caused the beta-uplift to be rolled back.  It will need to be applied to central as well to ensure that the same tests don't fail after merging central to beta.
Comment on attachment 8941669 [details]
Bug 1426500 - Disable WebVR for macOS on Beta and Release

As we passed the first merge, this needs to be release branch, too.
Attachment #8941669 - Flags: approval-mozilla-release+
let's make sure this makes it to 58 rc
Attachment #8942006 - Flags: review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/2a78b2a40796
Part 2: Update test_interfaces mochitest to expect WebVR interfaces to be disabled on release builds for macOS. r=smaug, a=me
It appears beta and release uplift approvals have been set, thanks!  Please be certain to include both patches to avoid test failures in beta and release.
Flags: needinfo?(kgilbert)
I verified the pref code (dom.vr.enable) accross some builds on macOS X 10.13.3 Beta. Here are the results: 

- Fx 58.0 - disabled
- Fx 58.0b16 - enabled (the uplift was after the merge)
- Fx 59.0b1 (Developer Edition) - disabled (the aurora channel should be enabled)
- Fx 59.0a1 - enabled

Will the pref code be disabled on the aurora channel until Fx 59.0b3(non-developer edition) will be compiled ? 

Thank you!
Flags: needinfo?(kgilbert)
(In reply to Cristian Comorasu [:CristiComo] from comment #19)
> I verified the pref code (dom.vr.enable) accross some builds on macOS X
> 10.13.3 Beta. Here are the results: 
> 
> - Fx 58.0 - disabled
> - Fx 58.0b16 - enabled (the uplift was after the merge)
> - Fx 59.0b1 (Developer Edition) - disabled (the aurora channel should be
> enabled)
> - Fx 59.0a1 - enabled
> 
> Will the pref code be disabled on the aurora channel until Fx
> 59.0b3(non-developer edition) will be compiled ? 
> 
> Thank you!

Thanks for verifying, Cristian!

The enabled state for macOS would be the union of dom.vr.enabled and dom.vr.openvr.enabled.

Priority is to disable in Fx 58 for release, so should be okay there.
For Fx 59, intention was to have it enabled for DevEdition but not on Beta or release.  (The patch looks for RELEASE_OR_BETA and disables on macOS if set).
Flags: needinfo?(kgilbert)
See Also: → 1438044
You need to log in before you can comment on or make changes to this bug.