Closed Bug 1426511 Opened 3 years ago Closed 3 years ago

Crash in mozilla::MediaPipelineReceiveAudio::PipelineListener::NotifyPullImpl

Categories

(Core :: WebRTC: Audio/Video, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1426171
Tracking Status
firefox59 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-6223b278-22f0-4fff-af2b-88d0a0171218.
=============================================================

Seen while looking at nightly crash data. Crashes started using 20171217220404: http://bit.ly/2B9Rki3. ni on :jya since code was touched in Bug 1404997

ni on 

Top 10 frames of crashing thread:

0 xul.dll mozilla::MediaPipelineReceiveAudio::PipelineListener::NotifyPullImpl media/webrtc/signaling/src/mediapipeline/MediaPipeline.cpp:2256
1 xul.dll mozilla::detail::ProxyFunctionRunnable<<lambda_e84b8043dccf09160bacf732377deee4>, mozilla::MozPromise<bool, bool, 1> >::Run xpcom/threads/MozPromise.h:1512
2 xul.dll mozilla::TaskQueue::Runner::Run xpcom/threads/TaskQueue.cpp:243
3 xul.dll nsThreadPool::Run xpcom/threads/nsThreadPool.cpp:228
4 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1039
5 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:508
6 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:334
7 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:319
8 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:299
9 xul.dll nsThread::ThreadFunc xpcom/threads/nsThread.cpp:423

=============================================================
Flags: needinfo?(jyavenard)
So it definitely could have happened :)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1426171
You need to log in before you can comment on or make changes to this bug.