--disable-ipv6 doesn't work on AIX

RESOLVED FIXED in 4.2.2

Status

NSPR
NSPR
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Wan-Teh Chang)

Tracking

4.1.2
4.2.2
Other
AIX

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
On AIX, USE_IPV6 is set to 1 by default.  It is not
possible to unset USE_IPV6 by passing --disable-ipv6
to mozilla/nsprpub/configure.
(Assignee)

Comment 1

16 years ago
Created attachment 82581 [details] [diff] [review]
Proposed patch.  Also remove _aix32in6.cfg.

I also found that it is no longer necessary to have
two separate files _aix32.cfg and _aix32in6.cfg, so
I remove _aix32in6.cfg and keep _aix32.cfg.

Comment 2

16 years ago
wtc: This patch works fine for me on AIX 4.3.3. I used it in my Mozilla 1.0rc2
build, and it works as expected.

Comment 3

16 years ago
*** Bug 139449 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
I must clarify that the --disable-ipv6 option is for
NSPR *developers*.  NSPR *clients* should not configure
NSPR with the --disable-ipv6 option.  If the
--disable-ipv6 option is specified, the NSPR build is
nonstandard and will not be supported by the NSPR group.
(Assignee)

Comment 5

16 years ago
Patch checked into the tip and NSPRPUB_PRE_4_2_CLIENT_BRANCH
of NSPR.

Note that the correct fix for the slow IPv6 DNS problem on AIX
is in bug 144886.  Do not solve that problem by configuring
NSPR with --disable-ipv6.  Please apply the patch in bug 144886.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.2.1
(Assignee)

Updated

16 years ago
Target Milestone: 4.2.1 → 4.2.2
You need to log in before you can comment on or make changes to this bug.