Closed Bug 1426817 Opened 5 years ago Closed 1 month ago

Add keyboard shortcuts to go back/forward in add-on manager

Categories

(Thunderbird :: Add-Ons: General, enhancement)

enhancement
Not set
normal

Tracking

(thunderbird102+ fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird102 + fixed

People

(Reporter: nONoNonO, Assigned: TbSync)

References

Details

Attachments

(1 file, 1 obsolete file)

In Firefox's add-on manager, it is possible to navigate with keyboard back and forward between the details of an add-on and the list of add-ons. I'd like to have that functionality also in Thunderbird.

I thought I've filed a bug for this earlier, but cannot find it anymore. I believe the response then was that this was typically a feature that would be implemented as an add-on, but I disagree with that. It is a very simple feature to add and a lot of users can benefit from it, but they probably won't take the action to install an add-on for it.

STR:
1. Open the add-on manager (Alt > Tools (Alt+T) > Add-ons (A)
2. Press Tab a few (5) times until an add-on is selected.
3. Press Enter to go to the add-on details
4. Press Ctrl+Left Arrow or Ctrl+[ to go back to the list of add-ons

Behavior:
Nothing happens

Expected behavior:
You should go back to the list of add-ons
Attached patch bug1426817.patch (obsolete) — Splinter Review
Attachment #8938621 - Flags: review?(acelists)
Comment on attachment 8938621 [details] [diff] [review]
bug1426817.patch

Paenglab, can you please look at this and also try the keys on Mac?
Attachment #8938621 - Flags: review?(acelists) → review?(richard.marti)
Onno, have you tried your patch? What key combinations should work?

On Linux and Windows, I use ALT+ArrowBack and ALT+ArrowForward to navigate in FX. Mac is CMD instead of ALT. On Swiss keyboard [ and ] are behind AltGr key. But also with en-US keyboard the navigation doesn't work  on FX and TB with [ and ].
I've only tested the patch on Thunderbird 52.5.2 and there it worked. Now on Thunderbird 59.0a1 the keys don't do anything. I had problems building and committing so I removed my patch locally a couple of times and I might have submitted the wrong version. I know I've tried a couple of different versions, with command and oncommand. The version with oncommand("goDoCommand('cmd_back');") did work.
On Windows both Alt+Left Arrow and Ctrl+[ should work with the patch. If not, either the patch or the keyboard layout is wrong.
Comment on attachment 8938621 [details] [diff] [review]
bug1426817.patch

Okay, I cancel the review now. Feel free to ask me when you have a working patch.
Attachment #8938621 - Flags: review?(richard.marti)
Whats the status here, any chance you can provide an updated patch? Is this still necessary with TB60?
Flags: needinfo?(o.e.ekker)
Component: General → Add-Ons: General
It isn't actually necessary, but it would be nice to have, not specifically for TB60, bur for any version.
I had this working locally once, but I have problems compiling TB locally, so it's hard to test.
I'll try to come up with a working patch, but this bug isn't assigned to me, so anyone can come up with an updated patch that does the trick…
Flags: needinfo?(o.e.ekker)

Onno/Paenglab - just wondering if you have managed to make any progress with this ? I've recently come back to Thunderbird from Outlook and loving its flexibility (again!). This lack of being able to go back in their internal 'browser' is driving me crazy, though. Would be fantastic if you managed to get this sorted. Even if it needs to be an addon, I'd be OK with that, but completely agree that shouldn't be the route to go down.

Many, many thanks in advance !

See Also: → 826196
Assignee: nobody → john
Status: NEW → ASSIGNED
Attachment #8938621 - Attachment is obsolete: true

The updated patch is adding support for ALT/ACCEL+left/right, but not for ALT+[ or ALT+], because those are no longer supported by Firefox.

Target Milestone: --- → 103 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a9411d1bacc9
Add support for keyboard shortcuts to go back/forward in add-on manager. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Regressions: 1772583
Regressions: 1772559

Comment on attachment 9278990 [details]
Bug 1426817 - Add support for keyboard shortcuts to go back/forward in add-on manager. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
No keyboard navigation in AOM

Testing completed (on c-c, etc.):
On Daily for two weeks
Risk to taking this patch (and alternatives if risky):
None

CAUTION: The first part of this patch (mail/base/content/messenger.xhtml:260-266) is not needed, it has already been uplifted.

Attachment #9278990 - Flags: approval-comm-beta?

Comment on attachment 9278990 [details]
Bug 1426817 - Add support for keyboard shortcuts to go back/forward in add-on manager. r=mkmelin

[Triage Comment]
Approved for beta

CAUTION: The first part of this patch (mail/base/content/messenger.xhtml:260-266) is not needed, it has already been uplifted.

Flags: needinfo?(rob)
Attachment #9278990 - Flags: approval-comm-beta? → approval-comm-beta+
Flags: needinfo?(rob)
You need to log in before you can comment on or make changes to this bug.