images show up as broken links

VERIFIED DUPLICATE of bug 189211

Status

()

VERIFIED DUPLICATE of bug 189211
17 years ago
15 years ago

People

(Reporter: bendspeirs, Assigned: jdunn)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Lots of images on this page show up as broken links...... but <right-click>
[view image] shows it fine.

I have already tried clearing cache, and reloading pages, -> nada.  

I have only seen it happen on this page.

They seem to be PNG files.  The files do not have any extension (".png")

Comment 1

17 years ago
Please always include build ID in bug-reports.

Comment 2

17 years ago
wfm using build 2002050507 on Linux (trunk).

Comment 3

17 years ago
WFM too - Linux as well as XP 2002050608.
Reporter: What are your cache setting in preferences?
Are you using image blocking of images from other domains?
(Yahoo normally use akamai for image serving)
(Reporter)

Comment 4

17 years ago
My first bug report.  Sorry about that.  2002050608


(Reporter)

Comment 5

17 years ago
You guys that say "wfm", are you actually signed in to Yahoo finance, or are you
just looking at the welcome page?

It only effects the dinamically generated images on the page (my accounts)

If you are not logged in, you will not be re-creating the problem.  If you are,
then I guess it is just me.

(Reporter)

Comment 6

17 years ago
I have tried multiple cache settings, "every time", "out of date", etc

I have tried blocking and then un-blocking images.

..... no change.

Comment 7

17 years ago
I saw this at the indicated url (didn't have to log into anything) on 2002050203
on macos8.6, over a modem fwiw.  Disabling keep-alive allowed the page to load
normally, so this looks suspiciously like 140176.
Assignee: Matti → darin
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
OS: Windows XP → All
QA Contact: imajes-qa → tever
Hardware: PC → All
(Reporter)

Comment 8

17 years ago
Tried turning on/off keep alive.  No change.

Just for giggles I fired up Netscape 6.2 (Gecko/20011019 Netscape6/6.2) and
tried it.  It works!  WTF?  I think this used to work a month ago in Mozilla
too.  Could it be recent breakage?

I'll try to recreate this at work tomorrow on WinNT.

..... need sleep......zzzzzzzzzzzzzz
(Reporter)

Comment 9

17 years ago
WFM at work on WindowsNT and Mozilla 2002050705.  So unless it got fixed 
overnight I must have something screwy going on at home or it is an XP-thing.

I'll try wiping the install of Mozilla at home.  Maybe the scorched earth 
approach will solve the problem and we can put this bug to bed.
(Reporter)

Comment 10

17 years ago
I think I have isolated this to something in my prefs.js file.  If I delete this
file and start Mozilla it shows the images.  If I copy my prefs.js file back and
restart I'm back to the no-show images.

Does this ring any bells?  

Is it safe to post this prefs.js file for people to look at?

Comment 11

17 years ago
ben: did you perhaps enable HTTP pipelining in the prefs?  also, if possible can
you check for differences between your "bad" prefs.js and your "good" prefs.js?

Comment 12

17 years ago
mass futuring of untargeted bugs
Target Milestone: --- → Future

Comment 13

17 years ago
Same problem detected with RC3 on Windows 98 in http://www.abreu.pt

Comment 14

17 years ago
Bug also detected in http://www.suprides.com/default01.asp

Comment 15

16 years ago
Is this still happening with a recent build and a new profile, if so please
comment otherwise please resolve this as WORKSFORME

Comment 16

16 years ago
*** Bug 153262 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
If this is not fixed then this might be related to / dupe of bug 88054

Comment 18

16 years ago
I'm having the same issue on my machine.  (Win XP, Moz 1.1 - 20020826)

Most images show up as broken links, on many sites.  Right-click/view image and
it they show up fine.  No ammount of cache clearing or settings changes seems to
have any effect.  I tried that Yahoo Finance page, and every image was broken
except the title bar.  Slashdot is another page that loads extremely poorly,
with the only image on the entire page being displayed, is the ad accross the
top.  =(

I was using 1.1b before, and everything worked fine.  And in fact, I tried going
back to it again once I started having the issues, and the images started
working again.

FYI, I always do an uninstal / clean install, and the only file I bother to copy
over is my bookmarks.  Also, I've only been using the posted builds, not any of
the nightly builds.  The 1.1b build that works is the one dated July 22, 2002.

Also, I just tried the before mentioned delete the prefs.js trick, with no success.

Let me know if anyone wants me to try anything else, or supply any more info.

Comment 19

16 years ago
I've fixed this issue on my machine, running Mozilla 1.1, build 20020826.

The culprit was my firewall, Norton Personal Firewall 2002.  As a test, I
disabled it, and all the images started working again.  And when I enabled it
again, all the images started breaking again, even images on sites that I had
just visited, which I thought was really odd.  I thought it would have just
pulled them from the cache.

I tested that Yahoo page, slashdot, and a bunch of other pages that I was having
trouble with before.  They all worked flawlessly with the firewall off.

So, I turned the firewall back on, and started playing around with the settings.
 What seemed to fix the broken images, was resetting the "Security Level" back
to medium.  After I made that change, I pointed Moz at a trouble site, and NPF
popped up with it's little "An app is attempting to access the internet..."
warning.  I selected "Allow...", and checked the "Always choose this option"
box.  Since then, Mozilla has worked perfectly, with all of the sites that were
causing trouble before.

I don't know why this wasn't an issue with earlier builds of Mozilla for me, but
at least it's fixed now.

I hope this information helps the rest of you with your issues.

Updated

16 years ago
Assignee: darin → pavlov
Component: Networking: HTTP → ImageLib
QA Contact: tever → tpreston

Comment 20

16 years ago
the original site is working for me but the sites listed in comment# 13 and
comment 14 show the broken images using todays trunk.  HTTP Pipelining is
disabled so that is not causing the problem.  

-> imagelib to take a look

Comment 21

16 years ago
http://slurmman.tripod.com/support.shtml is a page showing this weirdness
(seeing with as well current builds as NS7)

Comment 22

16 years ago
Looking at the source for this page, it looks like an HTML coding problem in
this instance. It has lt, quot and gt instead of less than signs, quotes and
greater than signs. I presume that isn't the problem with the original site.
(Assignee)

Comment 23

16 years ago
Or how about the links to the images themselves containing "\"
instead of "\" in the paths?

for example at http://www.suprides.com/default01.asp
I see the following
    <img border="0" src="img\Computador Suprides Neon.jpg"

So this sounds like a dup of bug 189211
Assignee: pavlov → jdunn
(Assignee)

Comment 24

16 years ago
The html is "bad"

"We've so far had the policy that we'll only "fixup" backslashes in URLs entered
directly into the URL bar.  The point is that "\" can be a legitimate character
in a URL.  RFC 2396 does not classify it as a delimiter.  That said, you are
correct that a number of websites make the mistake of assuming it is a valid
delimiter since IE treats it that way.  We have so far taken the approach that
we'll follow the RFC."

However, there is some discussion of how to actually "deal" with this.
In any event this is a dup of 189211, that actually poses a "different" 
issue, so while this is "older" I am going to dup of that, since that bug
actually shows another problem (not standards related) that might force a fix.

*** This bug has been marked as a duplicate of 189211 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.