Duplicate vertical scroll bar in the Response tab

VERIFIED FIXED in Firefox 59

Status

defect
P2
normal
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: magicp.jp, Assigned: rickychien)

Tracking

Trunk
Firefox 59
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 wontfix, firefox58 wontfix, firefox59 verified, firefox60 verified)

Details

Attachments

(4 attachments)

Reporter

Description

2 years ago
Steps to reproduce:
1. Launch Nightly
2. Open Netmonitor (Ctrl+Shift+E)
3. Set "CSS" requests list filter
4. Go to https://bugzilla.mozilla.org
5. Select "global.css"
6. Switch sidebar tab to "Response"

Actual results:
Duplicate vertical scroll bar. Particularly it is difficult to scroll because overlap them on Mac.

Expected results:
No duplicate.

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e16b6746b48f5a673888b4958ed3cb9192f7b1ab&tochange=cbf0cc9cb0b5ea2724e1b0586523ce6a275a991e
Reporter

Updated

2 years ago
Blocks: 1350226
Has Regression Range: --- → yes
Has STR: --- → yes
@Ricky, could bug Bug 1350226 cause this regression?

Honza
Flags: needinfo?(rchien)
Priority: -- → P2
I believe this is a regression after we merged preview tab into response panel. The editor-row-container should occupy the available vertical space as usual. Patch will be updated soon.
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: needinfo?(rchien)
Comment hidden (mozreview-request)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8940080 [details]
Bug 1426920 - Netmonitor ResponsePanel's editor-row-container should occupy the available vertical space

https://reviewboard.mozilla.org/r/210360/#review216112

The result looks right in response panel now, thanks!
Attachment #8940080 - Flags: review?(gasolin) → review+

Comment 6

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b85f17608702
Netmonitor ResponsePanel's editor-row-container should occupy the available vertical space r=gasolin

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b85f17608702
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Reporter

Comment 8

2 years ago
Posted video after-bug-fix.mp4
After bug fix, horizontal scrollbar does not appear until scroll to bottom. Please find expected.png
Flags: needinfo?(rchien)
Reporter

Comment 9

2 years ago
Posted image expected.png
Oh, thanks for the delicate check. I'll file a new bug to address this issue.
Flags: needinfo?(rchien)
Blocks: 1428521
It's too late for 58, mark 58 won't fix.

Comment 12

Last year
I have reproduced this bug with Nightly 59.0a1 (2017-12-23) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20180215111455
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [testday-20180216]
I verified the fix on Ubuntu 16.04 x64 and on macOS 10.13 using the latest Nightly 60.0a1 and beta 59.0b11, too. The issue is not reproducing anymore.

According to this result and the one from comment 12, I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.