Closed Bug 1427045 Opened 3 years ago Closed 3 years ago

Search glass missing from SeaMonkey search bar after Bug 1380268

Categories

(SeaMonkey :: Search, defect)

SeaMonkey 2.53 Branch
defect
Not set
minor

Tracking

(seamonkey2.53+ fixed, seamonkey2.54 wontfix, seamonkey2.55 fixed, seamonkey2.56 fixed)

RESOLVED FIXED
seamonkey2.56
Tracking Status
seamonkey2.53 + fixed
seamonkey2.54 --- wontfix
seamonkey2.55 --- fixed
seamonkey2.56 --- fixed

People

(Reporter: frg, Assigned: frg, NeedInfo)

Details

Attachments

(2 files, 2 obsolete files)

If you add a search field to a toolbar the glass icon at the right side is missing but can be clicked. Search-glass.png was removed in Bug 1380268 and replaced with a hard to see plain gray svg.
Stefan, I think you mentioned this before but I didn't find an existing bug.
Attachment #8938840 - Flags: review?(stefanh)
Comment on attachment 8938840 [details] [diff] [review]
1427045-searchglass-56.patch 2.53 version

On mac, I like the toolkit svg :-) Anyway, this doesn't affect mac, because the mac version of the file already use a png (which I don't think fit with the toolkit one that can be seen in the findbar... hmm).

Back to the subject: What about the icon in the findbar? Shouldn't that look the same?
Btw, the patch doesn't apply on trunk.
> One more thing: is the icon that you want to add the same as searchbar-search.png?

No. This is a gray icon and is actually looking ok. If it does have three states we could use it also. The search-glass.png was previously used for all search text boxes in toolkit (not on OSX).

> What about the icon in the findbar? Shouldn't that look the same?

Thought about it but it is a simple button image and was always different. Actually I would rather use svgs for everything too for better scaling but not so cheap looking :)

Sorry will rebase the patch. Did it on 2.53. 2.56 is still a basket case.
Attachment #8938840 - Attachment description: 1427045-searchglass.patch → 1427045-searchglass-56.patch 2.53 version
Attachment #8938840 - Flags: review?(stefanh)
Attached patch 1427045-searchglass.patch (obsolete) — Splinter Review
Patch for comm-central
Attachment #8938863 - Flags: review?(stefanh)
Comment on attachment 8938863 [details] [diff] [review]
1427045-searchglass.patch

+  skin/classic/communicator/icons/search-glass.png                      (communicator/icons/search-glass.png)

skin/classic/communicator/search/search-glass.png        (communicator/search/search-glass.png) is more consistent since there is already an icon in there used by communicator/search/searchbar.css). r=me with that fixed.
Attachment #8938863 - Flags: review?(stefanh) → review+
patch with icon moved to search. r+ from stefanh retained.
Attachment #8938840 - Attachment is obsolete: true
Attachment #8938863 - Attachment is obsolete: true
Attachment #8938870 - Flags: review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/6b5debab1881
Add back search-glass.png to SeaMonkeys Classic theme after it was removed in Bug 1380268. r=stefanh
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Hardware: All → Unspecified
Target Milestone: --- → Seamonkey2.56
Comment on attachment 8938870 [details] [diff] [review]
1427045-searchglass-V2.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1380268
User impact if declined: no incon in mail and browser search bar
Testing completed (on m-c, etc.): c-r 2.53
Risk to taking this patch (and alternatives if risky): none cosmetic
String changes made by this patch: --
Attachment #8938870 - Flags: approval-comm-beta?
Attached image Capture.PNG
Actually search.png also has three states so search-glass.png could replace it 1:1. I think search.png looks very outdated so let me know if I should do a followup bug.
Attachment #8938871 - Flags: feedback?(stefanh)
Attachment #8938871 - Flags: feedback?(iann_bugzilla)
Comment on attachment 8938870 [details] [diff] [review]
1427045-searchglass-V2.patch

a=me
Attachment #8938870 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 8938871 [details]
Capture.PNG

Not sure this is needed any more but f+ anyway
Attachment #8938871 - Flags: feedback?(iann_bugzilla) → feedback+
Some more padding might be required as it is a little close to "Search" and the button size has shrunk slightly
Comment on attachment 8938871 [details]
Capture.PNG

Note to myself: file a followup bug.
Flags: needinfo?(frgrahl)
Attachment #8938871 - Flags: feedback?(stefanh)
You need to log in before you can comment on or make changes to this bug.