Closed Bug 1427088 Opened 2 years ago Closed 2 years ago

Crash in mozilla::gl::GLContext::InitWithPrefixImpl

Categories

(Core :: Graphics, defect, critical)

57 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: philipp, Assigned: jgilbert)

References

Details

(Keywords: crash, regression, Whiteboard: gfx-noted)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-5bf45d47-9d8f-41e2-b7af-4bb7a0171223.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so mozilla::gl::GLContext::InitWithPrefixImpl gfx/gl/GLContext.cpp:867
1 libxul.so mozilla::gl::GLContext::InitWithPrefix gfx/gl/GLContext.cpp:347
2 libxul.so mozilla::gl::GLContextEGL::Init gfx/gl/GLContextProviderEGL.cpp:284
3 libxul.so mozilla::gl::GLContextEGL::CreateGLContext gfx/gl/GLContextProviderEGL.cpp:541
4 libxul.so mozilla::gl::GLContextEGL::CreateEGLPBufferOffscreenContext gfx/gl/GLContextProviderEGL.cpp:942
5 libxul.so mozilla::gl::GLContextProviderEGL::CreateHeadless gfx/gl/GLContextProviderEGL.cpp:960
6 libxul.so mozilla::widget::GfxInfo::GLStrings::EnsureInitialized widget/android/GfxInfo.cpp:76
7 libxul.so mozilla::widget::GfxInfo::EnsureInitialized widget/android/GfxInfo.cpp:37
8 libxul.so mozilla::widget::GfxInfo::GetFeatureStatusImpl widget/android/GfxInfo.cpp:403
9 libxul.so mozilla::widget::GfxInfoBase::GetFeatureStatus widget/GfxInfoBase.cpp:650

=============================================================

this fennec crash signature is regressing in volume in firefox 57 (but has been around before that already).
most of the crash reports come with MOZ_RELEASE_ASSERT(!err) added in bug 1339256.
Please help advise
Flags: needinfo?(bwu)
Jeff, 
Per comment 0, is this a regression from bug 1339256?
Flags: needinfo?(bwu) → needinfo?(jgilbert)
Uh, yeah, but that should indeed never ever be crashing.
Assignee: nobody → jgilbert
Component: General → Graphics
Flags: needinfo?(jgilbert)
Product: Firefox for Android → Core
Whiteboard: gfx-noted
Version: Firefox 57 → 57 Branch
This is the assert:
https://dxr.mozilla.org/mozilla-central/rev/351c75ab74c9a83db5c0662ba271b49479adb1f1/gfx/gl/GLContext.cpp#867
We can remove it, but the only time I can see it being hit is:
* Sudden context loss
* A bug we're not picking up on
So at least the ff57 reports have 0x501 in r0, which is INVALID_VALUE. (ff58 has r0:0x0, but that's probably a (bad) optimization)
My guess is that we're querying GL_NUM_EXTENSIONS because we see we have fGetStringi, but that entrypoint isn't actually supposed to be used for some reason. (es2 contexts?) This would cause INVALID_VALUE.
Comment on attachment 8940854 [details]
Bug 1427088 - Don't rely on glGetStringi just because it exists. -

https://reviewboard.mozilla.org/r/211102/#review216984

lgtm
Attachment #8940854 - Flags: review?(dmu) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/722f664d592a
Don't rely on glGetStringi just because it exists. - r=daoshengmu
https://hg.mozilla.org/mozilla-central/rev/722f664d592a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
it is something we want to uplift to 58?
Flags: needinfo?(jgilbert)
(In reply to Sylvestre Ledru [:sylvestre] from comment #10)
> it is something we want to uplift to 58?

This seems pretty low-volume, android-only, so probably not. If I'm reading the crash volume wrong, I'm willing to uplift it into late beta, but otherwise let's just let this already-on-release bug ride out 59.
Flags: needinfo?(jgilbert)
You need to log in before you can comment on or make changes to this bug.