The default bug view has changed. See this FAQ.

Document how to get the MathML fonts to work on Solaris

RESOLVED FIXED

Status

()

Core
MathML
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: rbs, Assigned: Roland Mainz)

Tracking

Trunk
x86
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
This is a follow-up to bug 120560.
(Reporter)

Comment 1

15 years ago
-> re-assigning
Assignee: rbs → Roland.Mainz
(Assignee)

Comment 2

15 years ago
Which kind of format is preferred - HTML or plain ascii text ?
(Reporter)

Comment 3

15 years ago
If you nicely summarize what to do as a comment in this bugzilla bug, I can
simply refer to your comment via a link from:
http://www.mozilla.org/projects/mathml/fonts/
(Assignee)

Comment 4

15 years ago
Here comes the doc:
-- snip --
Xservers which use the Adobe font engine (like Solaris Xsun and Xprt(=X print
server)) to render PostScript Type1 fonts may require extra steps to add new
fonts.

If you get some error messages (see /var/dt/Xerrors on Solaris) about PostScript
fonts like "FOOBAR not found, using Courier. CMEX0123 not found, using Courier."
etc.(and "Courier" is used instead of these fonts) then you need to do these
extra steps...

The Adobe font engine requires a "PostScript resource database" file named
"PSres.upr" to use the PostScript fonts correctly.
The solution is quite easy: Go to the font dir where the matching fonts
reside and run /usr/openwin/bin/makepsres to create "PSres.upr" after running
"mkfontdir".
The makepsres(1) manual page has some additional details about this subject
...
-- snip --

rbs/katakai:
If this description is OK for you then I can file a HTML version incl. links...
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

15 years ago
It is too cryptic. It needs an itemized listing of simple steps to do at each time:
1. do this
2. do that
...etc
(Reporter)

Comment 6

15 years ago
gisburn: still no 1-2-3 step-by-step procedure?

Comment 7

15 years ago
Running mkfontdir in the pfb font directory on Solaris 2.6 and 8 produces
a font.dir file with a single line of text in it that says "0"

Is this the expected output?

Comment 8

15 years ago
After running makepsres command in the pfb directory, a PSres.upr file was
generated and I seem to be able to add the pfb directory to my font path. We
also have Mathematica fonts already installed. However, if I go to the MathML
start page at http://www.mozilla.org/projects/mathml/start.xml I still get this
dreadful error that says: "To properly display the MathML op this page you need
to install the following fonts: CMSY10, CMEX10". However, all symbols "seem" to
be displayed correctly on that page. It would be nice if there was also a screen
shot of that page somewhere so that one could compare it to the mozilla rendering.
(Assignee)

Comment 9

15 years ago
rbs wrote:
> still no 1-2-3 step-by-step procedure?

Ouch. Somehow the bug disappeared from my radar... ;-(
(Assignee)

Comment 10

15 years ago
Short description, 2nd try:
-- snip --
Problem:
Solaris Xsun does not render MathML chars correctly and Solaris Xprt does not
print MathML chars correctly, both print the error message: "CMEX0123 not found,
using Courier." (where "CMEX0123" is the PostScript name of the font).

Cause of problem:
"PSres.upr" - PostScript resource database is missing, the Adobe Type1
rasterizer used by Solaris Xservers can't locate the font and fall-back to the
font "Courier".

Solution:
Steps to create the missing file (note you may have to do this procedure for
both Wolfram and TeX fonts):
1. Go to the location where the mathml fonts are installed (we're using
/home/sanja/mathml_fonts/tex_cmps/Type1/ in this example):
% cd /home/sanja/mathml_fonts/tex_cmps/Type1/
2. Create "PSres.upr" using the "makepsres" resource file
% makepsres
3. Validation:
Make sure the file has been created:
% ls -l PSres.upr
4. Remove the MathML fonts from the font math and re-add them:
% xset -fp /home/sanja/mathml_fonts/tex_cmps/Type1/
% xset +fp /home/sanja/mathml_fonts/tex_cmps/Type1/
5. Restart Mozilla

References:
BugZilla bug 142718 ("Document how to get the MathML fonts to work on Solaris")
has further references for this issue.
-- snip --
(Assignee)

Comment 11

15 years ago
Akop Pogosian wrote:
> Running mkfontdir in the pfb font directory on Solaris 2.6 and 8 produces
> a font.dir file with a single line of text in it that says "0"
> Is this the expected output?

Definately _not_.
For scaleable fonts there should be a "fonts.scale" file in the dir which gets
copied over to "fonts.dir".

Comment 12

15 years ago
To make the fonts.scale file in the pfb font directory, run this python script
with the argument ../afm

http://sketch.sourceforge.net/files/src/mkfontdb/

(Assignee)

Comment 13

15 years ago
Or use "type1inst" (see http://packages.debian.org/stable/utils/type1inst.html)
to create the fonts.scale entries for PFA/PFB fonts.

However, usually these fonts are shipped with the font archive itself.
(Reporter)

Comment 14

14 years ago
-> marking fixed. I have added a link from (see the section on "Troubleshooting"):
http://www.mozilla.org/projects/mathml/fonts/
to point here:
http://bugzilla.mozilla.org/show_bug.cgi?id=142718#c10
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 15

14 years ago
Environment: Mozilla 1.2.1 on Solaris 9, with the TeX CM and Mathematica fonts
added to the font path.

Followed instructions outlined in comment #10 which improved the situation very
much. However a new problem showed up (which was not there without the fonts):
the minus sign is missing -- see test 9 of the MathML torture test for example.
This problem seems to come from the TeX CM fonts and doesn't appear if only the
Mathematica fonts are added.
You need to log in before you can comment on or make changes to this bug.