Closed Bug 1427183 Opened 2 years ago Closed 2 years ago

Media Recorder pause/resume is not working correctly

Categories

(Core :: Audio/Video: Recording, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1296531

People

(Reporter: vzotov, Unassigned)

Details

(Whiteboard: [need info reporter 2018-01-12])

Attachments

(1 file)

Attached image firefox2.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36

Steps to reproduce:

FIREFOX ESR 52.5.0

Issue with Pause() - Resume() methods for media recorder steps to reproduce: 
- Start recording 
- recording video into blobs correctly 
- Pause recording 
....nothing happening.... it's correct because we paused recording 
- Continue recording .... nothing happening, it's incorrect because we resume recording 
- Stop the recording


Actual results:

After stopping recording appends a big blob with missed data between Continue - Pause state, but it also appends data between PAUSE - CONTINUE, that's incorrect, I click pause button and I don't want to record this time period between Pause-Continue state. https://www.screencast.com/t/sD7HPDIjtV1Y


Expected results:

- Start recording 
- recording video into blobs correctly 
- Pause recording 
....nothing happening.... it's correct because we paused recording 
- Continue recording
.... continue recording
- Stop the recording
Duplicate of this bug: 1427181
Component: Untriaged → Audio/Video: Recording
Product: Firefox → Core
Why is it duplicate? there are 2 different bugs, one for Firefox and another for Firefox ESR
Thanks for the report. The way that we do it is to have one bug and uplift the fix to the appropriate branch. Can you please upload the a script that reproduces case?
Flags: needinfo?(vzotov)
Whiteboard: [need info reporter 2018-01-12]
This was fixed as part of bug 1296531. Unfortunately it's too big to be uplifted to ESR52. But the good news is it was just released in 58, and will be part of 60.

Please file a new bug if you still encounter issues.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(vzotov)
Resolution: --- → DUPLICATE
Summary: Media Recorder API is not working correctly → Media Recorder pause/resume is not working correctly
Duplicate of bug: 1296531
(In reply to Andreas Pehrson [:pehrsons] from comment #4)
> and will be part of 60.

Will be part of ESR60 that is.
You need to log in before you can comment on or make changes to this bug.