Closed Bug 1427239 Opened 2 years ago Closed 2 years ago

Crash in java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.FormAssistPopup.destroy()'' on a null object reference at org.mozilla.gecko.webapps.WebAppActivity.onDestroy(WebAppActivity.java)

Categories

(Toolkit :: General, defect, critical)

59 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox58 --- unaffected
firefox59 --- verified
firefox60 --- verified

People

(Reporter: vihsaaa, Assigned: jchen)

Details

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-f4579e1b-5d1b-43a8-86c3-09bab0171228.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so GeckoAppShellSupport::ReportJavaCrash widget/android/nsAppShell.cpp:276
1 libxul.so mozilla::jni::NativeStub<mozilla::java::GeckoAppShell::ReportJavaCrash_t, GeckoAppShellSupport, mozilla::jni::Args<const mozilla::jni::Ref<mozilla::jni::TypedObject<_jthrowable*>, _jthrowable*>&, const mozilla::jni::StringParam&> >::Wrap<&GeckoAppShellSupport::ReportJavaCrash> widget/android/jni/Natives.h:778
2 data@app@org.mozilla.fennec_aurora-2@base.apk@classes.dex data@app@org.mozilla.fennec_aurora-2@base.apk@classes.dex@0xeff85d 
3 dalvik-non moving space (deleted) dalvik-non moving space @0x99c6 
4 dalvik-main space (deleted) dalvik-main space @0x167fe 
5 dalvik-main space (deleted) dalvik-main space @0x2af81e 
6 dalvik-main space (deleted) dalvik-main space @0x2e931e 
7 dalvik-main space (deleted) dalvik-main space @0x2e931e 
8 dalvik-non moving space (deleted) dalvik-non moving space @0x9e5e 
9 dalvik-main space (deleted) dalvik-main space @0x2e931e 

=============================================================
Crash Signature: [@ java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.FormAssistPopup.destroy()'' on a null object reference at org.mozilla.gecko.webapps.WebAppActivity.onDestroy(WebAppActivity.java)] → [@ java.lang.NullPointerException: Attempt to invoke virtual method ''void org.mozilla.gecko.FormAssistPopup.destroy()'' on a null object reference at org.mozilla.gecko.webapps.WebAppActivity.onDestroy(WebAppActivity.java)] [@ java.lang.NullPointerExcept…
Assignee: nobody → nchen
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
tracking-fennec: --- → ?
Comment on attachment 8949480 [details]
Bug 1427239 - Always create FormAssistPopup in WebAppActivity;

https://reviewboard.mozilla.org/r/218794/#review224604

lgtm
Attachment #8949480 - Flags: review?(droeh) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74f5b6977fbe
Always create FormAssistPopup in WebAppActivity; r=droeh
https://hg.mozilla.org/mozilla-central/rev/74f5b6977fbe
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Comment on attachment 8949480 [details]
Bug 1427239 - Always create FormAssistPopup in WebAppActivity;

Approval Request Comment
[Feature/Bug causing the regression]: n/a
[User impact if declined]: crash using web apps
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple fix for crash
[String changes made/needed]: none
Attachment #8949480 - Flags: approval-mozilla-beta?
Comment on attachment 8949480 [details]
Bug 1427239 - Always create FormAssistPopup in WebAppActivity;

Fix for a new crash in 59, let's take this for beta 10.
Attachment #8949480 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
No more crashes in nightly and beta since the patch landed.
Status: RESOLVED → VERIFIED
Removing tracking-fennec? flag because this bug has been fixed.
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.