Closed Bug 1427381 Opened 3 years ago Closed 1 year ago

[PDFium] Bottom part of embedded PDF files are cut/not printed

Categories

(Core :: Printing: Output, defect, P3)

x86
Windows 7
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox59 --- affected

People

(Reporter: StefanG_QA, Unassigned)

References

Details

Mozilla/5.0 (Windows NT 6.1; rv:59.0) Gecko/20100101 Firefox/59.0 (20171229100308)

Make sure to add the following pref: print.print_via_pdf_encoder : skia-pdf

1. Launch Nightly
2. Open a PDF file containing several images - *.pdf sample file. (https://bug1179262.bmoattachments.org/attachment.cgi?id=8628302)
3. Right-click each document and select the Print frame option from the context menu
4. Print the first and second page of each document
5. Compare the page with the actual document

AR: The bottom part is cut/ not printed

ER: The whole page should be printed
Blocks: 1399787
Assignee: nobody → cku
Assignee: cku → nobody
I guess it looks like to me that we can reproduce this phenomenon on non-PDFium.
This PDF size is 207.3mm x 296.7mm (near the A4?), then I tried to print this pdf as 'Letter'.

Stefan,
Can you reproduce this bug on non-PDFium, i.e. print.print_via_pdf_encoder = ""(empty)?
Flags: needinfo?(stefan.georgiev)
I`m able to reproduce the issue on Win7 x86 and Win10 x64 using latest Nightly build. 
I started to think this has to be an issue with the document itself.
We can mark this issue as invalid.
Flags: needinfo?(stefan.georgiev)
Only if the problem also happens when the pref print.print_via_pdf_encoder is set to the empty string.
[ Triage 2017/02/20: P3 ]
Priority: -- → P3

I'm closing this bug as WONTFIX per:

"The Mortar experiment has concluded. Mozilla does not consider the PDF use case justifies the burden of implementing and maintaining PDFium and a Pepper API implementation in Gecko."

Source: https://wiki.mozilla.org/Mortar_Project

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.